WebUI connection timeout after IP change

ezt

Guest
I know this has been asked before, but the answers I found didn't help out.

This problem occurs on a proxmox (v2) installation with only one host (i.e. no cluster).

After changing the IP in "/etc/network/interfaces" and "/etc/hosts" PING and SSH works, but I can't connect to the WebUI via https://<NewIP>:8006.

Things I've tried:
- reboot of the machine
- creation of a interfaces.new file + reboot
- setting the host parameter in "/usr/bin/pveproxy"

Are there any other files I should check for the old IP? How can I tell the WebServer (pveproxy?) to use the new IP?

Regards
 

ezt

Guest
I've restarted pveproxy by executing "service pveproxy restart" but it still doesn't work, sorry.

Thanks for your reply!

Best regards
 

postcd

Member
Sep 16, 2013
40
0
6
I had this problem too. Command "systemctl status pveproxy.service" returned "start failed - failed to get address info for: myoldhostname: Name or service not known" so i did "hostname mynewhostname" (mynewhostname do not contain any dots, should be only first part of the fqdn!), /etc/hostname and /etc/hosts should contain proper hostname and IP. Then i reload networking, restarted pveproxy "service pveproxy restart" the "worker" started. It may show this "/etc/pve/local/pve-ssl.key: failed to load local private key (key_file or key) at /usr/share/perl5/PVE/APIServer/AnyEvent.pm line 1626."
One may try command "pvecm updatecerts", restart or reboot. It started working for me then.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!