webmin in proxmox 2.0 Final

cosysco

Member
Mar 21, 2012
11
0
21
Hi guys!, happy proxmox2 for everyone!
I tried to install webmin on proxmox 2.0 Final. I can't install cuz have dependencies problem.

(Reading database ... 45138 files and directories currently installed.)
Preparing to replace webmin 1.580 (using webmin-current.deb) ...
Unpacking replacement webmin ...
dpkg: dependency problems prevent configuration of webmin:
webmin depends on libio-pty-perl; however:
Package libio-pty-perl is not installed.
webmin depends on apt-show-versions; however:
Package apt-show-versions is not installed.
dpkg: error processing webmin (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
webmin

Thanks for your help!
 

cosysco

Member
Mar 21, 2012
11
0
21
Hi... I've tried to install the dependencies

apt-get install libnet-ssleay-perl libauthen-pam-perl libio-pty-perl apt-show-versions libapt-pkg-perl

and this is the result...

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libio-pty-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package apt-show-versions is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libio-pty-perl' has no installation candidate
E: Package 'apt-show-versions' has no installation candidate
E: Unable to locate package libapt-pkg-perl


Please help!!!
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,659
973
173
I do not recommend to install webmin, but here are the mini instructions.

install needed dependencies:
Code:
aptitude update && aptitude install apt-show-versions libapt-pkg-perl libio-pty-perl

download webmin package manually with wget and install with:

Code:
dpkg -i webmin_1.580_all.deb
 

cle.ram

New Member
Jun 15, 2009
17
0
1
I guess the issue with webmin is that you introduce a potential security risk and that webmin itself perhaps could break other things, too. IMO I think that the Web-GUI of Proxmox should be rather sufficient for most administrative tasks and that you better keep your production systems as "clean" as possible compared to the reference Proxmox installation.
 
Last edited:

bd5hty

Active Member
Dec 27, 2011
99
0
26
China;Hangzhou
I guess the issue with webmin is that you introduce a potential security risk and that webmin itself perhaps could break other things, too. IMO I think that the Web-GUI of Proxmox should be rather sufficient for most administrative tasks and that you better keep your production systems as "clean" as possible compared to the reference Proxmox installation.
Agree with
 

nickh66

New Member
May 2, 2012
1
0
1
So, here is my problem today. Being a cowboy & all i went ahead & installed webmin on my proxmox 2.1 server (it's just a play thing so not the end of the world). I then went & ran an update on all packages found that could be updated. Apache was on the list.

One of the first things that the update did was to uninstall a couple of proxmox packages - YIKES!! Proxmox is buggered now.

Does anyone have any thoughts on how i might reinstall the missing packages - is it even possible now? I did this at work & i'm at home now so i cant recall the specific packages that were removed, but i do have a record of what they were.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!