Web UI Scroll up bug in chrome

Aug 12, 2019
15
1
8
28
Hi,
This bug is there since many updates for chrome, and for proxmox products.
The scroll able views when scrolled down to bottom start jumping backward many times when you start scrolling up.
This seems to happen only in chrome even with no extensions, firefox not effected.

To reproduce you can use a long vm list, long available updates list, or even the proxmox mailgateway tracking center list.
Reach the bottom, then start scrolling up, or even if you scroll to the middle try to go up.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,099
164
34
Vienna
using chrome or chromium here, i cannot reproduce the issue, neither on the left-hand tree, the datacenter search, the storage content view, the available updates list, etc.

what version of chrome do you have? and what does pveversion -v say?
 
Aug 12, 2019
15
1
8
28
using chrome or chromium here, i cannot reproduce the issue, neither on the left-hand tree, the datacenter search, the storage content view, the available updates list, etc.

what version of chrome do you have? and what does pveversion -v say?
Chrome: Version 90.0.4430.93 (Official Build) (64-bit) on windows 10

pveversion -v
Code:
proxmox-ve: 6.3-1 (running kernel: 5.4.78-2-pve)
pve-manager: 6.3-3 (running version: 6.3-3/eee5f901)
pve-kernel-5.4: 6.3-3
pve-kernel-helper: 6.3-3
pve-kernel-5.0: 6.0-11
pve-kernel-5.4.78-2-pve: 5.4.78-2
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.21-1-pve: 5.0.21-2
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.1.0-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 3.0.0-1+pve3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.20-pve1
libproxmox-acme-perl: 1.0.7
libproxmox-backup-qemu0: 1.0.2-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.3-2
libpve-guest-common-perl: 3.1-4
libpve-http-server-perl: 3.1-1
libpve-storage-perl: 6.3-4
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.8-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-3
pve-cluster: 6.2-1
pve-container: 3.3-2
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-8
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-3
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.5-pve1
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,506
1,756
164
South Tyrol/Italy
shop.proxmox.com
The vendor and model of the device you're using would be also interesting, sometimes things like a touchscreen can change the browser behavior quite a bit...
 
Aug 12, 2019
15
1
8
28
The vendor and model of the device you're using would be also interesting, sometimes things like a touchscreen can change the browser behavior quite a bit...
I use an asus notebook without touch screen. This happen with a normal mouse scroll button. We reproduce the issue on a macbook too with chrome, the result was the same.
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,099
164
34
Vienna
ok i think i can reproduce it, i'll look into it
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,099
164
34
Vienna
so, what i can reproduce is the following:

i click(!) on e.g. the first element so that it has focus (this is important)
now i scroll down until the view triggers its buffer change (this is done internally so that the dom is not polluted with 1000s of objects)
when that triggers, it tries to focus an element (that probably does not exist anymore) and the scrollbar jumps

is that what you encounter?
 
Aug 12, 2019
15
1
8
28
so, what i can reproduce is the following:

i click(!) on e.g. the first element so that it has focus (this is important)
now i scroll down until the view triggers its buffer change (this is done internally so that the dom is not polluted with 1000s of objects)
when that triggers, it tries to focus an element (that probably does not exist anymore) and the scrollbar jumps

is that what you encounter?
sadly its not true for me. i even don't hover the list. i can hover the scrollbar and scroll with the mouse wheel then happen. the list must be long enough like 20-30 scroll. should i make a video of it?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,099
164
34
Vienna
ok never saw anything like this (and i cannot reproduce that behaviour for sure)... do you always try with the same device (iow. mouse/trackpad/etc.) ? does do that on other sites as well (non-extjs based) ?
 
Aug 12, 2019
15
1
8
28
i tried the following combinations with the same result:
desktop pc, win 10, chrome, mouse
notebook, win 10 chrome, mouse and also trackpad
macbook, latest osx, chrome, trackpad

one thing maybe help: i don't need to scroll all the way down. At the half of the list when i start scrolling up, the list jumping down more and more till its reach the bottom. even if i scrolling up. when the bottom is reached i can go up normally again.
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,099
164
34
Vienna
i don't know whats different in your case, but it works totally fine here on linux+chrome/chromium, win10 + chrome
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!