web interface not working in Proxmox 3

Discussion in 'Proxmox VE: Installation and configuration' started by naja7host, Jun 13, 2013.

  1. naja7host

    naja7host Member

    Joined:
    May 15, 2009
    Messages:
    78
    Likes Received:
    0
    i cannot access the Web interface for my proxmox 3 with the url

    https://myserver.com:8006/

    in the log i have

    Code:
    root@xxxxx:~# tail /var/log/daemon.log
    Jun 12 23:49:40 xxxxx pveproxy[210723]: worker 432527 started
    Jun 12 23:49:40 xxxxx pveproxy[432527]: /etc/pve/local/pve-ssl.key: failed to load local private key (key_file or key) at /usr/share/perl5/PVE/HTTPServer.pm line 1125
    Jun 12 23:49:40 xxxxx pveproxy[210723]: worker 431838 finished
    Jun 12 23:49:40 xxxxx pveproxy[210723]: starting 1 worker(s)
    Jun 12 23:49:40 xxxxx pveproxy[210723]: worker 432548 started
    Jun 12 23:49:40 xxxxx pveproxy[432548]: /etc/pve/local/pve-ssl.key: failed to load local private key (key_file or key) at /usr/share/perl5/PVE/HTTPServer.pm line 1125
    Jun 12 23:49:41 xxxxx pveproxy[210723]: worker 431849 finished
    Jun 12 23:49:41 xxxxx pveproxy[210723]: starting 1 worker(s)
    Jun 12 23:49:41 xxxxx pveproxy[210723]: worker 432564 started
    Jun 12 23:49:41 xxxxx pveproxy[432564]: /etc/pve/local/pve-ssl.key: failed to load local private key (key_file or key) at /usr/share/perl5/PVE/HTTPServer.pm line 1125

    Code:
    root@xxxxx:~# pveproxy --debug
    unable to create socket - IO::Socket::INET: Address already in use

    i have rebooted the server with no success .

    any suggestion ?
     
  2. sdutremble

    sdutremble Member

    Joined:
    Sep 29, 2011
    Messages:
    85
    Likes Received:
    0
    Remove the apache package. It is no longer needed.

    Serge
     
  3. dietmar

    dietmar Proxmox Staff Member
    Staff Member

    Joined:
    Apr 28, 2005
    Messages:
    16,431
    Likes Received:
    298
    And what is the output of:

    # ls -l /etc/pve/local/pve-ssl.key
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Mantas

    Mantas New Member

    Joined:
    Jun 11, 2013
    Messages:
    3
    Likes Received:
    0

    We also experiencing the same issue

    output:
    cannot access /etc/pve/local/pve-ssl.key: No such file or directory


    pve-ssl.key as well as pve-ssl.pem are missing.

    Trying to create certificate. Got:
    writing new private key to 'key.pem'key.pem: Permission denied

    because permissions on directory: dr-xr-x--- 2 root www-data

    any ideas what is the best way to solve this?
     
  5. dietmar

    dietmar Proxmox Staff Member
    Staff Member

    Joined:
    Apr 28, 2005
    Messages:
    16,431
    Likes Received:
    298
    Does it help if you restart pve-cluster service:

    # service pve-cluster restart
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Mantas

    Mantas New Member

    Joined:
    Jun 11, 2013
    Messages:
    3
    Likes Received:
    0

    Yes, it helped to make folders editable(actually I rebooted whole server), so I created certificate and now I'm good.
    But this issue (no certificate files) happens every time we install new versions (3.0) of proxmox

    M.
     
  7. Mohamed Haisham

    Mohamed Haisham New Member

    Joined:
    Jul 1, 2013
    Messages:
    1
    Likes Received:
    1
    I ran into this problem a lot on several occasions.
    ie issues with (/etc/pve/local/pve-ssl.key)

    How to fix is.. i only tried this with new installs.

    make sure ip can be resolved to hostname

    That is ensure that
    listed hostname in /etc/hostname is listed in /etc/hosts with ipaddress

    then run pvecm updatecerts to regenerate certificates.

    hope this helps anyone who runs into this problem.
     
    Mr. Wolf likes this.
  8. RobFantini

    RobFantini Active Member
    Proxmox Subscriber

    Joined:
    May 24, 2012
    Messages:
    1,488
    Likes Received:
    21
    On a new install we ran into the same issue.

    Mohamed's suggestion to run pvecm updatecerts fixed the issue. [ Thank you Mohamed! ].

    /etc/hostname and /etc/hosts/ were OK.

    I used the same CD to install PVE on 2 other systems and did not have this issue.

    One thing was different on this install - the system did not have network access. the system has 3 nics and I had only the 2 on the motherboard attached to the switch. It turned out that eth0 was the 3-rd nic.

    So it might be possible to reproduce the missing /etc/pve/local/pve-ssl.key issue by trying to install without network access.
     
    #8 RobFantini, Jul 25, 2013
    Last edited: Jul 25, 2013
  9. KingLEV

    KingLEV New Member

    Joined:
    Jun 13, 2013
    Messages:
    10
    Likes Received:
    0
    My problem:

    # pveproxy --debug
    unable to create socket - IO::Socket::INET: Address already in use

    ls -l /etc/pve/local/pve-ssl.key
    -rw-r----- 1 root www-data 1679 Jun 19 13:37 /etc/pve/local/pve-ssl.key

    # ./pve-cluster restart
    Restarting pve cluster filesystem: pve-cluster[main] crit: unable to create lock '/var/lib/pve-cluster/.pmxcfs.lockfile': Read-only file system
    [main] notice: exit proxmox configuration filesystem (-1)
    (warning).

    My VM's continue working, but I can't control from web intreface. Help, please.
     
  10. jarcher

    jarcher Member

    Joined:
    Mar 15, 2009
    Messages:
    53
    Likes Received:
    0
    Thanks very much, it helped me!
     
  11. mathx

    mathx Member

    Joined:
    Jan 15, 2014
    Messages:
    89
    Likes Received:
    1
    need https:// to access interface. easily missed/forgotten :/
     
    #11 mathx, Jan 15, 2014
    Last edited: Jan 15, 2014
  12. Baatezu

    Baatezu New Member

    Joined:
    Sep 20, 2014
    Messages:
    1
    Likes Received:
    0
    Hello!
    Cannot connect to web
    Proxmox 3.3 fresh install and last update

    Syslog
    Code:
    proxmox1 pveproxy[9855]: problem with client ***.***.**.**; rsa_padding_check_pkcs1_type_1: block type is not 01
    proxmox1 pveproxy[9855]: WARNING: Can't call method "timeout_reset" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 225.
    
    Code:
    pveproxy --debug
    unable to create socket - IO::Socket::INET: Address already in use
    
    
    Apache not installed

    without cluster web is working

    plz help me :)


    FIX IT

    Solved: Clear cache
     
    #12 Baatezu, Sep 20, 2014
    Last edited: Sep 20, 2014
  13. tytanick

    tytanick Member

    Joined:
    Feb 25, 2013
    Messages:
    96
    Likes Received:
    3

    Exactly, and more precise, i needed to clear COOKIES (related to this server) in MY WEB BROWSER :)
    now its working, :p
     
  14. Posi

    Posi New Member

    Joined:
    Oct 16, 2016
    Messages:
    5
    Likes Received:
    0
    Try IE to connect. I think is a SSL thing. Using a browser that old works for me. Not I need to fix my cert.
     
  15. k1lerbee

    k1lerbee New Member

    Joined:
    Jan 9, 2018
    Messages:
    23
    Likes Received:
    0
    When I run pvecm updatecerts
    I get:
    pve configuration filesystem not mounted
     
  16. t.lamprecht

    t.lamprecht Proxmox Staff Member
    Staff Member

    Joined:
    Jul 28, 2015
    Messages:
    1,135
    Likes Received:
    147
    Can you try to start it, which then mounts it:
    Code:
    # PVE 3.X
    service pve-cluster start
    # PVE 4 and newer
    systemctl start pve-cluster
    
    If you are in a cluster you may do the same for corosync.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice