Warning: Remote Host Identification Has Changed error

neuron

Member
Mar 15, 2019
25
2
23
42
I have fives nodes in my cluster named pve0, pve1, pve2, pve3, pve4 and I can shell into all except pve2, which gives me this:

upload_2019-6-7_0-20-31.png

How do I even begin to make the suggested changes when I can't shell into the node? Thanks in advance.
 
Check your /etc/ssh/ssh_known_hosts on the local machine. It seems that you have an outdate fingerprint for pve2 (10.0.1.5).
How are you connecting to the server? Is this from a local ssh client or are you connecting via WebUI?
A `pvecm updatecerts` might help.
 
I ran that command on all my nodes - it seems to be working ok now. I think pve2 showed that error possibly due to my browser being wonky. It was showing it when I went directly to the Shell via Proxmox web GUI. I hadn't tried SSH. I didn't get this when I rebooted and re-logged into Proxmox with a fresh browser.
 
Glad it works, but I would not blame the browser in this case. ;)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!