[SOLVED] W2k16 Stop Code after P2V Migration

ulf.kosack

Renowned Member
Jan 28, 2012
48
7
73
Wachtberg
www.edvnet-uk.com
Hallo zusammen,

ich versuche einen Hardware-Server auf eine Proxmox-VM zu migrieren. Der alte Hardware-Server ist ein SuperMicro-Server inkl. Raid-Controller (falls das von Relevanz ist). Er wurde (vor 5 Jahren) mit UEFI BIOS installiert.

Ich stelle eine Vollsicherung von einem Synology NAS mittels Active Backup for Business wieder her. Die Wiederherstellung läuft auch vollständig durch. Für die Erkennung der Festplatten wurde bei der Wiederherstellung der Treiber von der virtio-win.iso (Vers. 0.1.240) geladen. Nur nach dem Neustart bekomme ich von Windows einen Stop-CODE "INACCESSIBLE BOOT DEVICE".
1698161449317.png
Die VM-Konfiguration sieht wie folgt aus:
1698161374867.png

Die Optionen wie folgt:
1698161405502.png

Der Boot-Bildschirm sieht wie folgt aus:
1698161500460.png

Ich habe es mit SCSI, VirtIO, IDE probiert. Den UEFI-Modus habe ich mit und ohne TPM probiert. Mit TPM lande ich in der UEFI-Shell.

SeaBIOS habe ich nicht probiert, da ich auf der Hardware schon gesehen habe, dass der Server mit UEFI installiert wurde.

Wer hat noch einen Tipp für mich, wie ich die VM nach der Wiederherstellung hochgefahren bekomme?

Der Vollständigkeit halber
Code:
root@pve01:~# pveversion
pve-manager/8.0.4/d258a813cfa6b390 (running kernel: 6.2.16-15-pve)

Code:
root@pve01:~# qm config 100
agent: 1
bios: ovmf
boot: order=ide2;scsi0;scsi1;scsi2;ide0
cores: 8
cpu: x86-64-v2-AES
efidisk0: SsdData:vm-100-disk-0,efitype=4m,size=4M
ide0: none,media=cdrom
ide2: none,media=cdrom
machine: pc-i440fx-8.0
memory: 32768
meta: creation-qemu=8.0.2,ctime=1697988923
name: XXXXXXX
net0: e1000=2E:B4:BF:D7:BD:D6,bridge=vmbr1,firewall=1,link_down=1,tag=1220
net1: e1000=BA:DA:6C:4E:6F:7F,bridge=vmbr1,firewall=1,link_down=1
numa: 0
ostype: win10
scsi0: SsdData:vm-100-disk-1,iothread=1,size=240G
scsi1: SsdData:vm-100-disk-2,iothread=1,size=240G
scsi2: HddData:vm-100-disk-0,iothread=1,size=8T
scsihw: virtio-scsi-single
smbios1: uuid=8c413bd0-d0ce-48fc-8b4e-cf4f2c19b1c6
sockets: 1
vmgenid: b4ba607c-bc55-44a2-a884-a27d39008448

Danke
Ulf
 
Last edited:
Hi @cwt ,

super.

Ich muss zugeben, dass ich nicht dran geglaubt habe, weil ich mir den Zusammenhang nicht vorstellen konnte. Aber mit der Integration des SCSI-Treibers im Windows-Image ist der Server wieder hochgefahren.

Und ich habe noch was gelernt. Geil.

1698246374548.png

Danke. Danke. Danke
 
  • Like
Reactions: cwt
Windows integriert Treiber nur in sein Image, wenn die Hardware auch vorhanden ist. Beispiel hierfür ist der „quick & dirty“ way bei VMs, wenn diese noch auf IDE/S-ATA stehen. Man fügt der VM eine zusätzliche vHDD als VioSCSI hinzu, fährt diese hoch und installiert den Treiber.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!