[SOLVED] W2012 R2 Inplace Upgrade / PVE 7.2-7

Minga

Member
Oct 20, 2020
40
1
13
Servus zusammen, das Inplace Upgrade von W2012 R2 auf 2016/2019 endet mit "0xC1900101 - 0x20017 The installation failed in the SAFE_OS phase with an error during BOOT operation". W2016 Inplace Upgrade auf W2019 oder eine W2019 GUI Reparatur-Installation laufen einwandfrei. Eine Neuinstallation mit W2012 R2 läuft einwandfrei. Ein Inplace Upgrade einer frischen W2012 R2 VM auf W2016/W2019 schlägt fehl. Es wurde i440fx und q35 (6.0, 6,1, 6.2) versucht. Bei ESXi muss die VM Version erweitert werden um das Problem zu lösen. Was ist bei PVE die Lösung? Grüße aus Minga
 
Unter 2012R12
Qemu Guest Agent deinstallieren
Virtio Treiber von der virtio-win-0.1.100.iso installieren (NetKVM, SCSI, Serial)
Q35 5.1 verwenden

eventuell nach die letzten windows6.x-hypervintegrationservices-x64.cab installieren

Danach sollte das Update funktionieren.
Ich bin seit einigen Wochen dabei mehrere Xen und Hyper-V Farmen nach Proxmox zu migrieren, bisher ging alles auch inkl. folgender inplace Updates auf neuere Windows Versionen.
 
Danke für die Rückmeldung. Ich werde das am Abend testen und Rückmeldung geben :)
 
Update. Ich habe gerade meine W2012 R2 Test VM upgraden können. Die Lösung war es den "alten" SCSI Treiber aus der virtio-win-0.1.100.iso zu installieren. Die Q35 Versionen haben keine Rolle gespielt. Das Upgrade hat auch mit q35-6.0 funktioniert. Herzlichen Dank und gutes Gelingen bei der Migration zu PROXMOX :)
 
Under 2012R12
Uninstalling Qemu Guest Agent
Install Virtio drivers from virtio-win-0.1.100.iso (NetKVM, SCSI, Serial)
Using Q35 5.1

You may want to install the latest Windows6.x HypervintegrationServices-x64.cab

After that, the update should work.
I have been migrating several Xen and Hyper-V farms to Proxmox for several weeks, so far everything went including the following inplace updates to newer Windows versions.
I did uninstall the Red Hat VirtIO SCSI pass-through controller... Then I cant install any other... and after restart it cant load the storage driver and the storage cant be read... and the startup fails…. How can I recover from this stage? Can I manually load the driver and get the vm to boot again?
 
I did uninstall the Red Hat VirtIO SCSI pass-through controller... Then I cant install any other... and after restart it cant load the storage driver and the storage cant be read... and the startup fails…. How can I recover from this stage? Can I manually load the driver and get the vm to boot again?
I manage to load the driver from the command prompt and and are able to read the harddrive:
1679247046849.png

"installed the driver"

then I run the "Startup Repair"... but no success... any idea on how to give my WIndows Server access and be able to start up Windows again?

1679246957089.png
 

Attachments

  • 1679247891343.png
    1679247891343.png
    23.7 KB · Views: 4
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!