[SOLVED] vncproxy problem solved - be aware of scripts in .bashrc!

marte

Member
Jun 28, 2019
18
1
23
46
I have a proxmox-Cluster consisting of two nodes. I had the exact same problem as described here, but no solution worked.

After many hours of not finding out why, I finally hit the solution and just wanted to share: I had some scripts running in .bashrc of root, like displaying of lxc ("lxc-ls"), qm ("qm list") and RAID status. It's noce to see this when logging in. But vncproxy does not seem to like this. After I deleted the lines, vncproxy started working in my cluster. Puh!

Maybe this can save anyone some hours...
 
You can keep your "scripts", but do it right and add these lines as the first lines in your .bashrc:

Code:
# do not run non-interactively
[ -z "$PS1" ] && return
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!