[SOLVED] VNC Connection refused on certain VMs

NE78

New Member
Aug 2, 2022
26
1
3
Hi, I am using RealVNC to VNC into my VMs. I can VNC into my Windows 2000 Pro VM (Just testing it) with no issues. However, I cannot VNC into a Fedora, Debian or Windows 10 environment.

Firewall is off for each OS just as a test, "The connection was refused by the computer".

I've modified the /etc/pve/local/qemu-server/id.conf for each one by adding:
Code:
args: -vnc 0.0.0.0:78

Each one has a unique port. Reset each VM after the config.

Edit: noVNC via the browser is working, but I do prefer a client.
 
Last edited:

NE78

New Member
Aug 2, 2022
26
1
3
I can't copy and paste for some reason.

netstat.JPG
This is in Fedora. Command doesn't work in Shell at PVE level.
 
Last edited:

NE78

New Member
Aug 2, 2022
26
1
3
Code:
tcp        0      0 0.0.0.0:5904            0.0.0.0:*               LISTEN      5831/kvm          
tcp        0      0 0.0.0.0:5902            0.0.0.0:*               LISTEN      5506/kvm          
tcp        0      0 0.0.0.0:5901            0.0.0.0:*               LISTEN      5710/kvm          
tcp        0      0 0.0.0.0:5977            0.0.0.0:*               LISTEN      2138/kvm

Edit: I realized that I said 78 in the first post, but meant what you see above.
 
Last edited:

NE78

New Member
Aug 2, 2022
26
1
3
Appreciate the help so far, hoping to move a little further on the path to getting this resolved. Thank you every one!
 

LnxBil

Famous Member
Feb 21, 2015
6,485
826
163
Saarland, Germany
So, the ports are open. That's good. Please try to connect to the vnc displays with your vncviewer and try each one of them. Normally the display is <port> - 5900
 

NE78

New Member
Aug 2, 2022
26
1
3
Correct, the ports are open, however, I get the following error when attempt to VNC into Fedora:
10.24.35.141:5902
"The connection was refused by the computer"

I have tried several VNC viewers. I can get into Windows 2000 just fine, but nothing else.
 

NE78

New Member
Aug 2, 2022
26
1
3
I've tried
10.24.35.141:02, 10.24.35.141:2, same error. conf.JPGcr.JPG
 
Last edited:

NE78

New Member
Aug 2, 2022
26
1
3
I should have listed everything I tried in one post, here's what I have tried in VNC Viewer:
Code:
10.24.35.141:02
10.24.35.141:2
10.24.35.141:5902
 

LnxBil

Famous Member
Feb 21, 2015
6,485
826
163
Saarland, Germany
I should have listed everything I tried in one post, here's what I have tried in VNC Viewer:
Code:
10.24.35.141:02
10.24.35.141:2
10.24.35.141:5902
Okay, thank you.

You said, you turned of the firewall for your VMs, that is one step, but did you also have any firewall rules on datacenter or host level? Normally they all are part of the firewall and a good rule on datacenter level will prohibit any further connection.

For testing purposes, I can recommend to have a "your-ip-all-allowed" rule that can be activated, but should normally be deactivated.
 

NE78

New Member
Aug 2, 2022
26
1
3
I don't remember turning off the firewall at the datacenter level, but it's off. I just turned off the firewall on the node level and that did not help either. It's bizarre that the "Win2k" box let's me right in, it's apart of the same node as well. I've compared the args against the others and the only difference is the port.
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
680
118
Good morning, any other suggestions?
* 10.24.35.141 is this IP address of your PVE server?

* are you on the same network segment as the PVE server?
 

NE78

New Member
Aug 2, 2022
26
1
3
The computer that I'm initiating the connection from is on a different subnet, however it has access to the destination.

10.24.35.141 is the Fedora install that I'm trying to VNC into.
10.24.35.14 is the PVE host.
The Windows 2000 box that I can VNC into, that resides on the same PVE host, is 10.24.35.20.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!