VNC connection refused from external client

Kevo

Well-Known Member
May 7, 2017
43
1
48
47
I followed the instructions on this page, https://pve.proxmox.com/wiki/VNC_Client_Access, but whenever I try and connect from an external client I get connection refused. This happens multiple clients. I haven't enabled any sort of firewall features and I am connecting from the local subnet.

Is there something I'm missing that I should check? I'm using ProxMox 5.3. TIA
 
what ip/port did you choose? and how did you try to connect?
 
I used 0.0.0.0:100 and I also tried :20 and :77 instead of :100. They all gave the same response. I used the IP of the proxmox server and the port to connect. So proxmoxip:5600 or :5920, or :5977. I tried the IP:port combinations on the built in vnc client on my Mac as well as VNC Viewer and Tiger VNC. They all gave the same response.
 
works here:

qm monitor ID
qm> change vnc 0.0.0.0:100
qm> quit

ss -tlpn:

Code:
...
LISTEN 0 1 0.0.0.0:6000 0.0.0.0:*
...

vncviewer IP:6000

Code:
TigerVNC Viewer 64-bit v1.7.0
Built on: 2017-04-09 14:55
Copyright (C) 1999-2016 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

Thu Mar 21 16:06:36 2019
 DecodeManager: Detected 32 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       connected to host IP port 6000
 CConnection: Server supports RFB protocol version 3.8
 
So I tried it through the shell instead of through the web interface, and it seems it's working now, sort of. I can connect, I just can't authenticate. I always get authentication failed in all the clients I've tried. Setting the password again doesn't seem to make a difference. I figure I'll restart the server at some point and try again, but haven't had a chance to do that yet.
 
I tried this on a different server through the shell only and I used the password version. I initially had the same problem. Connection refused. I tried again without the password, and same connection refused. I tried a third time with a different port and no password and now it's working. Neither of the ports I tried were in use according to ss. So I'm not sure what the problem is, but so far it seems the first attempt at setting this up seems to fail on both the servers I've tried. I will try it on a couple more servers to see if the pattern holds.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!