VMs wont boot

mcgnomer

New Member
Dec 8, 2019
5
0
1
35
Hi All, wow what a 24 hour period I've had. I'm looking for some help and going to try and give as much information as I can.
I am not a linux or proxmox power user by any means. I do this for fun and when I get the urge to do learning.
Code:
My Setup:
R710
ProxMox 5.4-13
2 raid arrays
250gb raid 1 - proxmox runs here.  I believe the lvm and lxc images are here too.
2tb raid 1 - This was passedthrough to my omv vm
4 - lxc containers
103
105
106
107
4 - VMs
100
101
102
104
DNS/DHCP is provided by my ERX router.
This set up has been working for about two years now.
Last night I was trying to get a new CentOS 7 minimal image to mount one of my NFS shares that OMV was providing.
(this is issue number 1, but low priority)

I installed nfs-utils on the client and ran sudo mount -t nfs -vvvv x.x.x.x:/export/serverstuff /home/nick/scripts and continually got operation not permitted, but i could see on omv the client was being authenticated.

I decided to update omv and then realized it was running low on space I gave for omv OS.
So I shut down the VM. Went to the proxmox gui, went into the hardware section of my vm and highlighted the sata0 local-lvm:vm-101-disk-0 and increased the size 1gig. This was more to just stop the low disk space alerts.

When I went to start the VM it gave me the following boot loop.
(problem 2, high priority)
Machine UUID xxxxxxxxxx
Booting from Hard Disk...
Boot failed: not a bootable disk


Thinking that I screwed my self. I detached that vm disk and added a new one with 8GB to do a fresh install of OMV.
I got to the part where it tells me to select the drive and i select the one that is not my pass through drive.
I then get an error
Failed to partition the selected disk. This probably happened because the selected disk or freespace is too small to be automatically partitioned.
Last I check omv only took 2gig
I did some googling and it apears newer version of omv require the same amount of swap as ram or something... I don't know how to do that with out build a whole new VM.
I gave up on trying to reinstall the omv for the time being and thooght I'll just pass the disk that is used for my NAS storage to a different VM so I can atleast back it up.

I passed that disk through to a ubuntu vm i use for a dedicated gaming server.
(problem 3, highest priority)

When i went to start the vm. I got the same boot loop error as before.
I had been prepping to remove this VM, but I needed one last look through it to make sure I got all my scripts and configs backed up... So being able to boot this VM again would be great.
I tried to run a qemu-img check vm-100-disk-1 and it says
qemu-img: Could not open 'vm-100-disk-1': Could not open 'vm-100-disk-1': No such file or directory. I'll be honest, i'm not sure if qemu-img is the correct diag tool here..
I'm having a really hard time understanding why adding the pass through drive to the 2nd VM screwed anything up with the boot drive.
So Now I have an 8TB external drive I picked up. I'd been planning to start backing up my NAS for a while anyway, but this just tells me I really need to start.
Issue list:
  1. My dedicated game server VM wont boot, says "booting from hard disk. Boot failed: not a bootable disk."
  2. OMV server has the same error as above
  3. If I can't get omv or the vm back how do I get the data of my disk and put it on my usb hdd. (can i do that from proxmox somehow?)

I will be more than willing to answer questions as to other troubleshooting I have done or run any diagnostic commands I can. I've spent 5 to 6 hours of the past 24 trying to get these resolved, I don't want it to seem like I've got a problem and put no effort into fixing it.

Any assistance on any of the issues would be appreciated.
Thank you!
 

mcgnomer

New Member
Dec 8, 2019
5
0
1
35
Anyone have any ideas? I'm getting close to just mount /dev/sdb to a directory in proxmox backing it up and installing the latest version of proxmox.
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
5,372
362
103
Hi,

this has nothing to do with your problem but please do not use sata vdisk bus.
The sata is only for legacy compatibility.

Please send the output of the following commands

Code:
lsblk
zfs list
lvs
pveversion -v
megacli -AdpAllInfo -aAll
Also, the config of the two guests are helpfull
 

mcgnomer

New Member
Dec 8, 2019
5
0
1
35
Sorry for the delayed response

lsblk
Code:
root@R710:~# lsblk
NAME                         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                            8:0    0 232.4G  0 disk
├─sda1                         8:1    0     1M  0 part
├─sda2                         8:2    0   256M  0 part
└─sda3                         8:3    0 232.1G  0 part
  ├─pve-swap                 253:0    0     8G  0 lvm  [SWAP]
  ├─pve-root                 253:1    0    58G  0 lvm  /
  ├─pve-data_tmeta           253:2    0    76M  0 lvm 
  │ └─pve-data-tpool         253:4    0 150.1G  0 lvm 
  │   ├─pve-data             253:5    0 150.1G  0 lvm 
  │   ├─pve-vm--100--disk--1 253:6    0    30G  0 lvm 
  │   ├─pve-vm--101--disk--1 253:7    0     4G  0 lvm 
  │   ├─pve-vm--102--disk--1 253:8    0     7G  0 lvm 
  │   ├─pve-vm--104--disk--1 253:9    0    50G  0 lvm 
  │   ├─pve-vm--105--disk--1 253:10   0     8G  0 lvm 
  │   ├─pve-vm--106--disk--1 253:11   0     4G  0 lvm 
  │   ├─pve-vm--103--disk--0 253:12   0    20G  0 lvm 
  │   ├─pve-vm--107--disk--0 253:13   0     5G  0 lvm 
  │   └─pve-vm--101--disk--0 253:14   0     8G  0 lvm 
  └─pve-data_tdata           253:3    0 150.1G  0 lvm 
    └─pve-data-tpool         253:4    0 150.1G  0 lvm 
      ├─pve-data             253:5    0 150.1G  0 lvm 
      ├─pve-vm--100--disk--1 253:6    0    30G  0 lvm 
      ├─pve-vm--101--disk--1 253:7    0     4G  0 lvm 
      ├─pve-vm--102--disk--1 253:8    0     7G  0 lvm 
      ├─pve-vm--104--disk--1 253:9    0    50G  0 lvm 
      ├─pve-vm--105--disk--1 253:10   0     8G  0 lvm 
      ├─pve-vm--106--disk--1 253:11   0     4G  0 lvm 
      ├─pve-vm--103--disk--0 253:12   0    20G  0 lvm 
      ├─pve-vm--107--disk--0 253:13   0     5G  0 lvm 
      └─pve-vm--101--disk--0 253:14   0     8G  0 lvm 
sdb                            8:16   0   1.8T  0 disk
└─sdb1                         8:17   0   1.8T  0 part /home/data
sdc                            8:32   0   7.3T  0 disk
└─sdc1                         8:33   0   7.3T  0 part /mnt/usb
root@R710:~#
zfs list
Code:
root@R710:~# zfs list
no datasets available
lvs
Code:
:~# lvs
  LV            VG  Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  data          pve twi-aotz-- 150.12g             61.72  39.32                           
  root          pve -wi-ao----  58.00g                                                   
  swap          pve -wi-ao----   8.00g                                                   
  vm-100-disk-1 pve Vwi-a-tz--  30.00g data        83.33                                 
  vm-101-disk-0 pve Vwi-a-tz--   8.00g data        0.00                                   
  vm-101-disk-1 pve Vwi-a-tz--   4.00g data        46.63                                 
  vm-102-disk-1 pve Vwi-aotz--   7.00g data        60.05                                 
  vm-103-disk-0 pve Vwi-aotz--  20.00g data        63.63                                 
  vm-104-disk-1 pve Vwi-aotz--  50.00g data        93.01                                 
  vm-105-disk-1 pve Vwi-aotz--   8.00g data        8.98                                   
  vm-106-disk-1 pve Vwi-aotz--   4.00g data        17.21                                 
  vm-107-disk-0 pve Vwi-aotz--   5.00g data        18.94                                 
root@R710:~#
pveversion -v
Code:
root@R710:~# pveversion -v
proxmox-ve: 5.4-2 (running kernel: 4.15.18-21-pve)
pve-manager: 5.4-13 (running version: 5.4-13/aee6f0ec)
pve-kernel-4.15: 5.4-9
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.13.4-1-pve: 4.13.4-26
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-55
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-7
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-40
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-54
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
megacli -AdpAllInfo -aAll
Code:
@R710:~# megacli -AdpAllInfo -aAll
-bash: megacli: command not found
VM 1
1576636071438.png
VM 2
1576636106362.png
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
5,372
362
103
The config looks ok.
But please show from the options tab the boot order.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!