VMs suddenly stop.

Jim Surles

Member
May 29, 2018
6
0
6
50
Hello,

I've run into a situation where one VM just abruptly stops. There is actually no stop record that I can find, it just no longer is running. The logs on the machine don't indicate anyone shutting it down.. as a matter of fact, the logging on the device seems to have stopped several hours before.

This has happened 3 times now. I go in and start it up, and it seems to run just fine.. for a 3 days, then blip, offline again. Every 3 days. (12/3, 12/6, and now 12/9) and always at the same time.

One of the unusual items is that the VM system stops looking around 0400 UTC, then the machine stays online and responding to monitoring until about 1400 UTC. When I log into the web gui, it just shows it as being down, but starts right up like it's just fine. No records that I can find for the VM in question to have stopped.

Thoughts.. hints, places to look?

Running 5.2-10
 
Happened to me due OOM killer killed one of the VM processes when RAM usage was increasing, but not critical at all. Or at least I did not notice RAM starvation. The VM then stops without trace in tasks. Not sure if this is your case, just check RAM usage at first.
 
  • Like
Reactions: is25

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!