[SOLVED] Vms not booting after physical server reboot

Stryder

New Member
Oct 27, 2012
27
0
1
Hello to all Proxmox Forum team.
I Just complete successfully the import of 4 vms into a new proxmox 5.0 install.
kernel:4.10.17-2
pvemanager:5.0-30

After a physical server reboot, vms won't boot, they can't find their volumes, but if I go to local-lvm or run lvs I can see them there.
After runing a lvscan Just realize /dev/pve/data is marked as inactive
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
1,501
213
63
South Tyrol/Italy
Hi. Just as a note Proxmox VE 5.0 is well over two years old, and you should at least upgrade the host to 5.4. Normally compatibility in a stable release stays the same or gets even better (bug fixes).

Hmm, is anything weird/errorneous in the syslog/journal?

Can you just activate it:
Code:
lvchange -a y /dev/pve/data
 
  • Like
Reactions: Stryder

Stryder

New Member
Oct 27, 2012
27
0
1
Thanks Thomas for your reply, Already Tried, but I get
Check of pool pve/data failed (status 1). manual repair required!
any ideas? Thinking a bit now, I import those vms (initially .raw) files, from a failed hdd running an older proxmox version.
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
1,501
213
63
South Tyrol/Italy

Stryder

New Member
Oct 27, 2012
27
0
1
OK problem is solved, I ran lvconvert --repair /pve/data, after verifying volume was deactivated lvs -a
then lvchange -ay /dev/pve/data , reboot the physical server.
Thanks Thomas and all forum team for your time solving my case.
Great Job.....!!! we can mark this thread as SOLVED
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!