[SOLVED] vmlinuz-5.0.21-3-pve has invalid signature


New Member
Oct 20, 2019
Fresh install on Debian Buster, following this install guide, adapted to Buster.
On reboot, I get this:

Loading Linux 5.0.21-3-pve ...
error: /boot/vmlinuz-5.0.21-3-pve has invalid signature.
Loading initial ramdisk ...
error: you need to load the kernel first.

and will not boot using that kernel. However it will boot using 4.19.0-6 from Debian

Any pointers?
Thank you!!
hmm - seems the error-message is Secure Boot related (maybe the simplest workaround would be to disable secureboot in BIOS)

Maybe the documentation on Secure Boot from the debian-wiki can help if you want to use Secure boot - https://wiki.debian.org/SecureBoot

Which boot-loader are you using on that system?

I hope this helps!
Glad it solved the problem!

Please mark the thread as 'SOLVED' - it helps others in a similar situation



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!