VM Wipe ??! - HDD data lost


New Member
Jun 9, 2019
I have these problem first time and it is really big problem. I had there my projects and important data. It Vm was working correctly before restart.
After node restarted one ov my VMs didnt start. It was saying:

So I tried to restore it from backup. I have 5 backups for 5 days. But it doesnt help. I was also trying to restore backup on other node, but it still doesnt work. When I try to boot on that VM live/cd Gparted Tools it looks like HDD of that VM is wiped like "unlocated". And my backups have size about 5GB so how is that possible ??!


Please help me. I dont need to get that VM work. Just get data from its HDD.
Best way to post a VM config is to use the CLI command "qm config <vmid>" and put it in a CODE Tag ;)

I see there is one unused disk, did you tried to boot from the unused one and see what happens?
Are you sure you boot from the other one? Did you removed the other one or changed the boot device?
And there was no data on any of the two disks? Try to boot a GRML or gparted and check the partition layout, if there is no one you should try to scan the disks with a file recovery tool. Otherwise you can try to install grub on it again.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!