VM Read-only file system


New Member
Jan 20, 2021

I installed new Virtual Machine to Proxmox. Configured it, but made a mistake in fstab, so after restart it shows:

Unknow Error 3
Unexpected inconsistency

I know where is error in fstab, but I can't edit it -> read only mode. Is there any chance to correct it or do I need to re-create VM?

Boot from a Linux live iso image.
Mount your drive and edit fstab.
Then you should be able to boot again.
Glad it worked for you. Please set the thread to solved by editing the first post.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!