VM port issue


May 6, 2019
I'm a fresh user of Proxmox trying to move some of my VM-load from Unraid to my earlier bare-metal Pfsense-router.
Almost everything is running fine, with the exception of a connection issue in one of my VMs.
My Proxmox-server currently contains a VM for Pfsense and a VM for Homeseer (home automation software running on W10).
One of my plugins is trying to connect to two arduino's via a plugin. From homeseer's log, the connection fails when trying to connect to the arduino's on port 8900.
I've disabled all the firewalls on both Proxmox and W10, but still no luck. I can also ping the IP of the arduinos just fine. On my old Unraid-VM everything is working as it should, so it has to be something with my Proxmox config. Do I have to do some port forwarding? I consider the virtual bridges as switches..

My homeseer-VM is currently connected to vmbr0, but I've also tried vmbr2 (both as linux bridge and OVS bridge), and also without the ip/subnet configured as pfsense should handle this. The VM has IP, and the arduino's and 178.

# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
# If you want to manage parts of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT read its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

auto enp3s0
iface enp3s0 inet manual

auto enp1s0f0
iface enp1s0f0 inet manual

allow-vmbr2 enp1s0f1
iface enp1s0f1 inet manual
ovs_type OVSPort
ovs_bridge vmbr2

auto vmbr0
iface vmbr0 inet static
bridge-ports enp3s0
bridge-stp off
bridge-fd 0

auto vmbr1
iface vmbr1 inet manual
bridge-ports enp1s0f0
bridge-stp off
bridge-fd 0

auto vmbr2
iface vmbr2 inet static
ovs_type OVSBridge
ovs_ports enp1s0f1
root@proxmox:~# pveversion -v
proxmox-ve: 5.4-1 (running kernel: 4.15.18-13-pve)
pve-manager: 5.4-5 (running version: 5.4-5/c6fdb264)
pve-kernel-4.15: 5.4-1
pve-kernel-4.15.18-13-pve: 4.15.18-37
pve-kernel-4.15.18-12-pve: 4.15.18-36
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-51
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-41
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
openvswitch-switch: 2.7.0-3
proxmox-widget-toolkit: 1.0-26
pve-cluster: 5.0-36
pve-container: 2.0-37
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-20
pve-firmware: 2.0-6
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-3
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-50
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
It's unusual to have 2 (physical) interfaces connected to the same subnet ( with independent IP addresses. However, for the VM it does not count.

Suggest to follow the IP packets from the Windows VM to the Arduinos and back. Assuming your VM-ID is 100 which has just one virtual NIC it would be in the Proxmox host:
tcpdump -e -n -i tap100i0 
tcpdump -e -n -i vmbr0 
tcpdump -e -n -i enp3s0
Inside Windows you can use wireshark for investigating packets.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!