VM of windows 11 error


New Member
Oct 9, 2023

i tried to instal win 11 via vm. i get following error

swtpm_setup: Not overwriting existing state file.
kvm: -device ide-cd,bus=ide.0,unit=1,drive=drive-ide1,id=ide1,bootindex=100: Can't create IDE unit 1, bus supports only 1 units
stopping swtpm instance (pid 9530) due to QEMU startup error
TASK ERROR: start failed: QEMU exited with code 1

i tried to add a cd/dvd and add vitio dvd image to support driver installation. then now removed. even now eeror comes. how to make proper win 11 installation?

should i use virtio iso too for drivers?
Yes and with the virtio drivers installed you shouldn't use IDE fpr your virtual harddisks in the first place...IDE is super slow and doesn't support discard which is needed by thin-provisioned storages like the default LVM-thin or ZFS you are probably using...
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!