VM of DietPi

nuentes

New Member
Jun 29, 2019
6
0
1
42
I've now been working on this for about 8 hours, and I am ready to beg for help.

I can't seem to get a VM of DietPi up and running. It appears the DietPi doesn't officially support Proxmox, however I can't think of any reason why it wouldn't work. I just feel like every failure I've faced was due to user error in some way. Here is what I tried:

Other device install - I installed Debian 10, and then tried to run the scripts, and I got errors every time. I then tried to install Debian 8 (Jesse), and still was getting errors every time. I can the commands through SSH. It runs for a while, and then fails.

Native PC (UEFI): I must be doing something wrong, because whenever I set the BIOS to UEFI (and add an EFI Disk), I can't boot to anything. I was able to get the clonezilla portion to run in SeaBIOS, but whenever I switch to EFI, the image won't load.

I also downloaded the DietPi Virtualbox file, and found how to convert the vmdk to qcow2 and then convert that to RAW. I overwrote the appropriate file in /var/lib/vz/images/ (creating the VM 3 different times with each different format) and then tried to boot and just get more errors.

And I know I'm not giving good documentation on what errors I faced. Again, I've been at this for 8 hours straight now. I'm dying. Could some kind soul just install this for me and give me documentation on what I need to do to just get DietPi up and running or something?

I chose to use DietPi as my primary OS for a few different tasks because I thought it would save me time, but I'm being proven wrong.
 
Never used DietPi and I'm bored so I downloaded the "Native PC (BIOS)" flavor to try it out. First issue is that it is a 7z-compressed disk image file, NOT an ISO. I think that's b/c the SBC's it normally runs on tend to boot from SD. So what I did was this:
  • Create a VM with mostly default settings. I did change the CPU type to "host" and set the "ssd" flag on the disk.
  • Unzip the IMG file and SCP it over to my server. Had to use the command line for this b/c the GUI doesn't know what an "IMG" file is.
  • Overwrite the virtual disk with the IMG. I'm using lvm-thin storage and the VMID was 107 so that command looked like:
    • dd if=DietPi_v6.25_NativePC-BIOS-x86_64-Buster.img of=/dev/mapper/vg1-vm--107--disk--0 bs=4M
  • Booted that sucker up. And it worked.
It seems to boot to RAM and then formats the entire disk that it finds. So I ended up with a 32GB partition with 2.4G used. Which is actually not all that "diet" compared to, say, Alpine Linux, which is under 400 MB for a basic install. It isn't really smaller than a base Debian TBH. My router/gateway is on Debian 10 and it is 1.8 GB.

I use Alpine for those single-purpose VM's. The ISO installs fine in Proxmox with no special jiggering. It also very well-behaved in containers and there's a pre-done template in Proxmox.
 
Hm - not sure why it's taking up 32GB, and that's definitely a problem for me. I was hoping to spin 3 of these up, ranging from 4-16GB. The appeal of DietPi is the low system resources (mostly RAM and CPU), and ease of installing certain preconfigured applications.

I hadn't tried to use the IMG you used, because that was an IMG file and I didn't know what to do with that in Proxmox. The UEFI version also requires a 32GB drive, so I would have preferred using the virtualbox or vmware images, as those are a better example of why it is "Diet".

I'll play around with your method listed above. If you're still bored, perhaps you can help crack using the vmdk file...
 
Ugh. I don't know what I'm doing wrong. I basically kept the defaults as well. I also used LVM-thin. SCP's it to Proxmox. I ran the command, and it looks like it ran fine

upload_2019-7-20_22-53-41.png

And when I try to run the VM, this is what I get.

upload_2019-7-20_22-51-14.png
 
The 32 GB was the disk size, only 2.4 was used. But like I said, that is not smaller than a base Debian and much larger than a base Alpine.

I think one of a few things is wrong. One is, are you 100% sure the device you wrote the image to is the one that the VM is trying to boot from? Verify your config. Here's what I have:

Code:
root@vm-host:~# qm config 107
boot: cdn
bootdisk: scsi0
cores: 1
cpu: host
ide2: none,media=cdrom
machine: q35
memory: 512
name: dietpi
net0: virtio=1E:FC:98:3C:38:B9,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: local-lvm:vm-107-disk-0,size=32G,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=fb22d438-bfce-4098-b28e-8e0cb5355613
sockets: 1
vmgenid: 4396b524-8a1f-4c23-b796-eb5cf35707f0

Next would be that the image is the wrong one or corrupt. You shortened the name so I can't tell if it is the same one I used. Here's the MD5 of mine.

Code:
bobh@robin:~/tmp/dietpi$ md5sum DietPi_v6.25_NativePC-BIOS-x86_64-Buster.img
b25819b36ee62581cd27f25083cf2ff3  DietPi_v6.25_NativePC-BIOS-x86_64-Buster.img

Also, does the image have a DOS boot sector?

Code:
bobh@robin:~/tmp/dietpi$ file DietPi_v6.25_NativePC-BIOS-x86_64-Buster.img
DietPi_v6.25_NativePC-BIOS-x86_64-Buster.img: DOS/MBR boot sector

Can't think of anything else right now.
 
Thanks so much for getting back to me. I know the image was correct (I had just renamed it so it would be easier to SCP over - I downloaded it from their website yesterday, just like you did).

Possible it was the DOS boot sector. I can't remember. I've abandoned Proxmox. I was just having too much trouble, and I decided I want to use DietPi more than I want to use Proxmox. So I'm just using Lubuntu for my base OS. Thanks again for trying, but I'm just a lost cause.
 
I don't if you tried recently but now the Native PC for BIOS/CSM offers an iso than when you boot this iso, by default Clonezilla will clone an image to your drive. The issue is CloneZilla image expects at least a 128G drive but it works.
 
Hi all!

I suspect that by then many of you have already dealt with it yourself, but I leave a link to the qcow2 image for future visitors made by myself.

Image is based on Debian.

The method of use is simple. Create a new virtual machine according to the scheme below (other settings than described below depends on your own choice):

Guest OS:
Type: Linux
Version: 5.x - 2.6 Kernel

Hard Disk:
Bus/Device: SCSI
Disk size: 10
Format: QEMU image format (qcow2)
Cache: Write back

BIOS: Default (SeaBIOS)
Machine: Default (i440fx)

After that replace the disk file with the one downloaded from me also changing XXX in the name of qcow2 image according to your freshly created VM-ID

Image link:
https://drive.google.com/file/d/15lRQe3g6rnPROvA7cJHfvlmw2hTE4SQj/view?usp=sharing

After startup setup is also good to:
Code:
apt install qemu-guest-agent

If you want to expand disk size after instalation just resize it in ProxMox and later attach any live-cd of Ubuntu and from there you can easly adjust partition size to disk size using GParted. (tip. "turn off" swap partition. Delete it. Resize main partition and recreate swap in the end of drive. After that "turn on swap").

Cheers!
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!