[SOLVED] VM not utilizing whole disk space


New Member
Oct 17, 2023
Hey guys,
I setup proxmox a couple of month ago and only now find out that I probably made some mistakes.

My usecase:
Proxmox is installed on a 256GB SSD. I added a 4TB SSD. For now I only need one VM where I run all my services in Docker (nextcloud, immich, wireguard and much more). My plan was to use the small SSD only for proxmox and use the 4TB only for my main VM. I seem to have messed up as my VM only has 98GB:

This is the VM:

This is the 4TB SSD where my VM seems to be running on:

When I remember correctly I assigned 1TB to the VM when I created it. Why are only 98GB available in the VM tho? And how can I change that so that the VM has access to the whole 4TB?

Did I messed up something entirely?

I am quite lost as I thought I followed the setup quite textbook-like. Maybe someone can help me how to fix this or guide me to some resources.

Thanks a lot in advance!

can you please post the output of the following commands inside the VM?
- lsblk
- pvs
- vgdisplay
- lvdisplay

As the disk size is correct from the PVE side, I'd say that Ubuntu simply created the LVM with 100GB space and not used the full disk. The above should confirm that.
  • Like
Reactions: MrNimbus

so yeah, that confirms it - while the disk is 1TB as you specified, the Ubuntu installer seems to allocate only a part of the disk. Doesn't surprise me all that much tho that Ubuntu does such non-sensical things.

Below procedure is of course on your own risk, so take a backup before! Just to be on the safe side.

In any case, to resize the root partition to it's full size:
pvresize /dev/mapper/ubuntu--vg-ubuntu--lv /dev/sda3
lvresize /dev/ubuntu-vg/ubuntu-lv /dev/sda3
resize2fs /dev/mapper/ubuntu--vg-ubuntu--lv
That should 1) resize the volume group to the partition size, than 2) grow the logical volume to that size too and 3) finally resize the filesystem to the new size.

The last step assumes you used ext4 as root filesystem, which I guessed based on that you used a standard Ubuntu install.
  • Like
Reactions: MrNimbus
That resolved my problem thank you very much!
If I now wanted to increase the VM disk space even more (more than the originally allocated 1TB) I need to increase the hard disk size on the VM settings and probably run the 3 commands again am I right?
Not sure if this is the best solution
Hi all!
Returning this topic.

I have this scenario and commands above don't work. I assume is because my case is quite different from the user @Dunuin


Is it possible to resize sda2 with the 210G of sda3 ?.

When i want to run first command i got this.


Thanks a lot!

PD: The commands above help me out in another scenario quite well!.

Those are partitions and not LVs. You need to work with the partitioning tool of your choice. Easiest would be to boot a gparted ISO for a GUI.
Those are partitions and not LVs. You need to work with the partitioning tool of your choice. Easiest would be to boot a gparted ISO for a GUI.
Uhm ok...is ubuntu server, so no GUI.

Any clue about what procedure to follow?.

Gparted is its own Live Linux, so it doesn't matter what OS you are running. Boot the VM from that ISO and you will have a GUI.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!