VM and nNode status bogus

Mrt12

Active Member
May 19, 2019
92
7
28
44
Since a few days, my 2nd PVE node cannot display its status, and I cannot access the VMs (shell) from the web gui. Everything seems to work fine, though.
What could be the reason for this kind of problem?
Note that on both nodes, I run the latest Proxmox for which I used the update procedure as described in the Wiki, and it worked well, but pve2 is weird since a few days.
The VMs on it run fine, though, and I can log in via SSH, but not via the web GUI.
 

Attachments

  • Screenshot_2019-09-24_13-33-51.png
    Screenshot_2019-09-24_13-33-51.png
    28.3 KB · Views: 3
this can happen if the 'pvestatd' daemon is not providing current information
the most common cause is that there is some storage defined for which the status check is hanging (e.g. for nfs)
 
thanks. I restarted pvestatd service and now the pve2 node looks good. I don't know what caused pvestatd to hang or crash, but it was for sure not the storage because the storage works just fine. However, restarting the pvestatd service solved the problem and now everything looks good again.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!