[SOLVED] Virtual Machine won't boot


New Member
Apr 12, 2022
I'm not sure what happened. I was performing apt updates on the Proxmox host and a VM and containers. I got to my Ubuntu VM, logged onto it and did and "apt update". I can't recall the exact words, but apt failed and said my disk space was full. So, I used the GUI to add 5GB. I thought I read that it wasn't necessary to reboot, but the VM was still showing full, so I rebooted. The boot gets to here:
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... Volume group "ubuntu-vg" not found
  cannot process volume group ubuntu-vg
Then, it drops me to an (initramfs) prompt.

I really don't believe it was the updating or changing the disk size that triggered the issue. I feel like it has something to do with changing the hostname a few weeks ago.

I have a vzdump backup from 10/1. I could try restoring it. But, I'd rather punch through this.

One other noteworthy thing is that I'd been noticing that Proxmox was using quite a bit of my 64GB of memory and the VM was maxing it's allotted memory, too.

Got any suggestions on how to troubleshoot this?

EDIT: I just wanted to follow up with this to say that the issue has been resolved. I would go into great step by step detail, but I've done so much that it would be difficult and I'd probably end up misleading. However, as close as I can recall:

The solution began with booting the VM to a live OS. Clonezilla worked well for me, as it boots to a command prompt pretty fast.

After that, I tried so many things that I really lose track of the steps. I am pretty sure that chrooting to the virtual disk via the live OS and running initramfs-update -u enabled my VM to start booting. But, the issue wasn't completely resolved. After rebooting, I noticed that the VM wasn't aware that I had increased the size of the disk from within Proxmox. So, I had to correct that, too.

Not ever having interacted with LVM before, I was a bit of a fish out of water. I'm too old school and LVM has just worked. Anyway, I just wanted to mark it solved and hopefully point someone in the right direction.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!