[SOLVED] VE 5.4 dist-upgrade failed. Node running but failing as 7 services not configured


Aug 28, 2019
Hi all.

I did a dist-upgrade of a single node proxmox ve 5.3 install. The install did not complete and now the system is incomplete. The icons in the GUI have missing parts (no 'running' arrow near the VMs) and cannot make bakcups of some VMs. I get a lock advice but a unllock command does nothing.

Running some executables is not possible. For example pveversion is killed as soon as it starts:

root@bilbo:~# pveversion -v

I tried a new apt dist-upgrade but it fails:

root@bilbo:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
7 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (137)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

I tried a force install, failed too. I tried to install pve-manager and got a lot of unconfigured errors. After following the unconfigured chain trying to configure them I get down to pve-cluster that fail with the shown error:

root@bilbo:~# dpkg --configure pve-cluster
Setting up pve-cluster (5.0-38) ...
/var/lib/dpkg/info/pve-cluster.postinst: line 38: 8157 Killed deb-systemd-helper unmask pve-cluster.service > /dev/null
/var/lib/dpkg/info/pve-cluster.postinst: line 49: 8158 Killed deb-systemd-helper --quiet was-enabled pve-cluster.service
/var/lib/dpkg/info/pve-cluster.postinst: line 49: 8159 Killed deb-systemd-helper update-state pve-cluster.service > /dev/null
Job for pve-ha-lrm.service failed because a fatal signal was delivered to the control process.
See "systemctl status pve-ha-lrm.service" and "journalctl -xe" for details.
dpkg: error processing package pve-cluster (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:

And that is all. I do not know what to do now. Can someone help me?

Thanks in advance.
Well, I answer myself.

The problem has fixed itself. The host PC went down yesterday and it was booted again today. When I entered the GUI now all icons were showing fine and I were able to start the backup of the VM that it was locked before.

Then I installed htop cause I like more that interface and I got surprised to see that pve-cluster were being configured and then, thereafter, came all other that were dependant of it including qemu-server and pve-manager:

Processing triggers for mime-support (3.60) ...
Processing triggers for man-db ( ...
Setting up pve-cluster (5.0-38) ...
Setting up htop (2.0.2-1) ...
Setting up libpve-storage-perl (5.0-44) ...
Setting up libpve-access-control (5.1-12) ...
Setting up pve-container (2.0-40) ...
Processing triggers for pve-ha-manager (2.0-9) ...
Setting up qemu-server (5.0-54) ...
Setting up pve-manager (5.4-13) ...
Setting up proxmox-ve (5.4-2) ...
Processing triggers for systemd (232-25+deb9u11) ...
Processing triggers for pve-ha-manager (2.0-9) ...
W: APT had planned for dpkg to do more than it reported back (23 vs 27).
Affected packages: pve-cluster:amd64

After that pveversion now works and no more update errors.

So issue resolved.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!