USB issue after plugging it

rjcab

Member
Mar 1, 2021
49
0
11
44
Hello,

I have the latest version of Proxmox installed on a mini PC (Core I9 64GRAM 1T nvme).
I have a WIN11 VM which works well and I have attached a touch screen (HDMI with USB)

The GPU Passthrough works well, I start the VM and everything works. After 1min about, the screen still shows up the desktop, the VM runs but the touch screen doesn't reply anymore. I tried to remove the USB and replug it, it works again for 1 min:

Code:
[1715448.659603] hid-multitouch 0003:2575:0401.000D: input,hiddev0,hidraw0: USB HID v1.10 Mouse [Weida Hi-Tech                CoolTouchR System           ] on usb-0000:00:14.0-5/input0
[1719475.846616]  sda: sda1 sda2
[1769366.736182] usb 1-5: USB disconnect, device number 19
[1769378.707877] usb 1-5: new full-speed USB device number 20 using xhci_hcd
[1769378.861115] usb 1-5: New USB device found, idVendor=2575, idProduct=0401, bcdDevice=14.30
[1769378.861120] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[1769378.861122] usb 1-5: Product: CoolTouchR System           
[1769378.861123] usb 1-5: Manufacturer: Weida Hi-Tech               
[1769378.864960] input: Weida Hi-Tech                CoolTouchR System            Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/0003:2575:0401.000E/input/input44
[1769378.865084] input: Weida Hi-Tech                CoolTouchR System            as /devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/0003:2575:0401.000E/input/input45
[1769378.865155] hid-multitouch 0003:2575:0401.000E: input,hiddev0,hidraw0: USB HID v1.10 Mouse [Weida Hi-Tech                CoolTouchR System           ] on usb-0000:00:14.0-5/input0
[1769379.336121] usb 1-5: reset full-speed USB device number 20 using xhci_hcd
root@pve:~#

My config of WIN 11:

Code:
  GNU nano 5.4                                                                           /etc/pve/qemu-server/100.conf                                                                                   
agent: 1
bios: ovmf
boot: order=scsi0
cores: 4
efidisk0: local:100/vm-100-disk-1.qcow2,efitype=4m,pre-enrolled-keys=1,size=528K
hostpci0: 0000:01:00.0,pcie=1
machine: q35
memory: 7000
meta: creation-qemu=7.2.0,ctime=1685382213
name: tactile
net0: virtio=82:94:86:08:45:84,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
parent: drivers_downloaded
scsi0: local:100/vm-100-disk-0.qcow2,iothread=1,size=32G
scsihw: virtio-scsi-single
smbios1: uuid=9cb36676-6cXXXXX1-a3a4-0534f64778b6
sockets: 1
vga: none
vmgenid: c738a5cc-cd7XXXXXXX-8580-edfddda4f323

Code:
root@pve:~# cat /etc/modprobe.d/vfio.conf
options vfio-pci ids=2575:0401
root@pve:~#
If you have any ideas :) Many Thanks
 
i don't see a usb passthrough config in your vm config, is that deliberate ?

i'd check the energy settings for the usb port for example
 
Thank you for your reply. You are right, but on the GUI I see my usb:
 

Attachments

  • Untitled.png
    Untitled.png
    126.3 KB · Views: 12
Not sure what USB specs your touch screen has, but:

- try plugging in the touch screen directly into the mini pc, without any USB hubs etc.
- try switchting the touch screen between USB 2 and USB 3 ports (high speed, full speed)
- double click (edit) the USB properties in the vm (your screenshot) and activate/disable USB3,
try Use USB Vendor / Use USB port
 
Last edited:
thats not the same vm, you posted the config of vm '100' and the screenshot is of vm '101'

also, please check the usb energy saving settings (bios/host/guest) maybe they get automatically suspended, etc.
 
Oh my god, my mistake:

The right conf:

Code:
gent: 1
bios: ovmf
boot: order=ide0;ide2
cores: 4
efidisk0: local:101/vm-101-disk-0.qcow2,efitype=4m,pre-enrolled-keys=1,size=528K
hostpci0: 0000:01:00.0,pcie=1
ide0: local:101/vm-101-disk-1.qcow2,size=32G,ssd=1
ide2: local:iso/virtio-win-0.1.229.iso,media=cdrom,size=522284K
machine: pc-q35-7.2
memory: 9000
meta: creation-qemu=7.2.0,ctime=1686944620
name: W11
net0: e1000=4E:54:FB:65:71:98,bridge=vmbr0,firewall=1
numa: 0
ostype: win11
scsihw: virtio-scsi-single
smbios1: uuid=80c32686-xxxx-458a-8e2b-6c0a1cacb2a9
sockets: 2
tpmstate0: local:101/vm-101-disk-2.raw,size=4M,version=v2.0
usb0: host=1-5
vga: none
vmgenid: 783586c4-20a0-xxxx-9011-a330a2acce75

Already tried to remove the USB and replug it. It works for 1 min too.

Already tried to change the USB port. It works for 1 min too.
 
I will check for usb energy saving settings (bios/host/guest) but for other VM it works well, no issue.
I will test also to deactivate USB3. For USB Vendor / Device ID, already tested, not worked
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!