USB hard drive no longer shareable

Manny Vazquez

Well-Known Member
Jul 12, 2017
106
2
58
Miami, FL USA
I just run into a weird situation.
I have a USB drive attached to one of my nodes and shared as storage to all other nodes, it has been working perfect over the last year (378 days to be exact).
Over the weekend I wanted to do some clean up and decided to reboot all nodes. This went on without a problem, restarted all the VMs perfectly fine and quorum was re-established.
I even saw the Shared usbdrive listed on the storage and check (on the server where the drive is attached) and saw it fine.
When the backups run overnight (this is what I use the usb drive for), I got errors saying the path was not accessible, at that point is that I realized the drive is not accessible any more.

It is mounted properly and the node that it is connected to can read it fine (and write) but it is not accessible via the Shared Storage.

I deleted the Storage (via the gui)
upload_2019-4-15_15-24-42.png
And tried adding it again but everytime I try to share it, the whole cluster seems to disappear for like a minute. And even that sometimes it seems to have worked, the drive is still not accessible , now not even to the node where it is connected.

I can still use it via terminal, So I started local backups and transfer via scp to the usb drive, but it is not as efficient as backing up directly to the drive.

I have tried many things but now I am completely lost, any ideas?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!