[SOLVED] Updating ProxMox 5.4-15 Error!

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Dear All,

Hope you all are doing great!

In fact I am tiring to update my proxmox 5.4-14 but but this what I have within /etc/apt/sources.list:

1626519254520.png

and commented out the /etc/apt/sources.list.d/

1626519341159.png



when I try to execute apt dist-update:

1626519446906.png

Could you please help me how to fix and update it?!!!!

Thank you so muc.
 

birdy

Active Member
May 14, 2021
144
39
28
In your first screenshot there are 4 lines (forget the blue ones they're just comments). The first three are for the Debian-updates (debian.org), the fourth is for Proxmox (proxmox.com).

Debian is the baseinstall of your server and Proxmox adds to that their stuff. Both need to be on the same version of Debian (so either all "Stretch" for PVE 5.x or all "Buster" for PVE 6.x). Are you updating your current (5.x) version or upgrading to 6.x? If only updating change "buster" to "stretch"in the fourth line. If you want to upgrade (which I assume) follow the doucument.
 
  • Like
Reactions: YaseenKamala

birdy

Active Member
May 14, 2021
144
39
28
Last edited:

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Please read the documents. The boys (and girls?) at Proxmox put time and effort in them to make the upgrade as smooth as possible for us.

https://pve.proxmox.com/wiki/Category:HOWTO

https://pve.proxmox.com/wiki/Upgrade_from_5.x_to_6.0

PVE5 > Debian 9 "Stretch"
PVE6 > Debian 10 "Buster
PVE7 > Debian 11 "Bullseye"

You can't directly upgrade to PVE7 from PVE5. You need to upgrade to PVE6 first and then to PVE7.
Totally agreed I was not sure what to read exactly since I am a bit new with ProxMox that is why I am keep asking. Indeed the documentations are really clear detailed.
 

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Good luck upgrading and let us know the outcome.
For sure Ill let know the end of in any case, but I have one more question to you when I try to check
Code:
pve5to6
I have 2 WARNINGS one is about that there are still VMs running this goes away when I stop the VMs → OK

However the second one I really don't understand fully what it is about exactly! could you please give me an idea to know what to do with. below is the warning message details:

WARN: updates for the following packages are available: proxmox-widget-toolkit, corosync, libcfg7, libknet1, libdevmapper1.02.1, dmsetup, libcmap4, libpve-access-control, libpve-cluster-perl, proxmox-mini-journalreader, ifupdown, libpve-storage-perl, libpve-cluster-perl, proxmox-backup-client, proxmox-backup-file-restore, grub-common, pve-firmware, libquorum5, ksm-control-daemon, pve-qemu-kvm, libspice-server1, libproxmox-backup-qemu0, libdevmapper-event1.02.1, pve-docs, pve-ha-manager, libpve-cluster-perl, dmeventd, liblvm2cmd2.03, zfs-initramfs, lvm2, grub2-common, pve-firewall, libpve-cluster-perl, libjs-extjs, pve-container, libpve-cluster-perl, pve-lxc-syscalld, libklibc, zfs-zed, libnvpair3linux, libuutil3linux, libzfs4linux, grub-pc, pve-cluster, librados2-perl, vncterm, spiceterm, libspice-server1, ipmitool, zfsutils-linux, libnvpair3linux, libuutil3linux, libzfs4linux, libzpool4linux, grub-pc-bin, pve-i18n, pve-xtermjs, libpve-u2f-server-perl, grub-efi-amd64-bin, pve-manager, libproxmox-acme-perl, libpve-cluster-api-perl, libpve-cluster-perl, zstd, libvotequorum8, spl, libzfs2linux, libpve-guest-common-perl, libpve-cluster-perl, novnc-pve, libpve-common-perl, libproxmox-acme-perl, libyaml-libyaml-perl, lxc-pve, qemu-server, libpve-cluster-perl, smartmontools, libzpool2linux, grub-efi-ia32-bin, pve-edk2-firmware, libpve-http-server-perl, libjs-jquery, libjs-bootstrap, criu, python-future, libnvpair1linux, omping, libuutil1linux, libcpg4, klibc-utils, libpve-apiclient-perl, libcorosync-common4, lxcfs​
 
Last edited:

birdy

Active Member
May 14, 2021
144
39
28
Hmm, I'm not sure.

Did you change anything in the /etc/apt/sources.list (first screenshot)?

If not, please do the following:

- in the fourth line change "buster" in "stretch".
- then do a regular update to get PVE5 at the latest level
- try pve5to6 again
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!