Updating microcode and pinned kernels


New Member
Sep 25, 2023
Update: I think I solved my issues.

1. To get the microcode to take the lower kernel, I went to /boot and removed all references of the kernel I wanted to get rid of, and then ran the microcode update. I was already running the kernel version I wanted and had it pinned with proxmox-boot-tool.
2. For the 8505, looking at the release notes, 0x42c seems to be the latest. So I think I am good there now too.


Hey all

I am trying to install the intel-microcode_3.20230808.1~deb12u1_amd64.deb package for my processor.

I have two nodes, one with an Intel 8505, and another with an N95.

N95 | 06-BE-00
8505 | 06-9A-04

The microcode website looks like there are entries for 20230808 on there:

On my N95 box, I have pinned kernel 6.2.16-3-pve because of some dependencies on my Realtek NIC.

Whenever I run dpkg -i intel-microcode_3.20230808.1~deb12u1_amd64.deb , or I run tteck's Microcode updater, the installer generates a new image for 6.2.16-14-pve (or whatever latest kernel is running). I have tried removing the kernels, but upon a reboot, a new kernel is just added.

root@pve:/tmp# dpkg -i intel-microcode_3.20230808.1~deb12u1_amd64.deb
(Reading database ... 101031 files and directories currently installed.)
Preparing to unpack intel-microcode_3.20230808.1~deb12u1_amd64.deb ...
Unpacking intel-microcode (3.20230808.1~deb12u1) over (3.20230808.1~deb12u1) ...
Setting up intel-microcode (3.20230808.1~deb12u1) ...
update-initramfs: deferring update (trigger activated)
intel-microcode: microcode will be updated at next boot
Processing triggers for initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-6.2.16-14-pve
Running hook script 'zz-proxmox-boot'..
Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace..
No /etc/kernel/proxmox-boot-uuids found, skipping ESP sync.

Is there a way to prevent the newer kernels from being added to my machine automatically if I am trying to use an older kernel?

Edit: For the 8505, looking at the release notes, 0x42c seems to be the latest. Still need to figure out how to update it for the N95 running an older kernel though.

On my 8505 box, I am running 6.2.16-14-pve currently, but have been having some stability issues, so I may try downgrading the kernel to see if that helps.

However, even running the current kernel, after upgrading, the output says I am on an older microcode version?

root@router:~# journalctl -k | grep -E "microcode: microcode"
Oct 03 11:58:33 router kernel: microcode: microcode updated early to revision 0x42c, date = 2023-04-18

I'm having trouble making sense of whether or not I'm actually on the microcode revision I installed.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!