[SOLVED] Update: openrc / sysv-rc

frantek

Member
May 30, 2009
160
4
18
Hi,

lately I've done (as usual) updates on my nodes and got:

Code:
**********************************************************************
*** WARNING: if you are replacing sysv-rc by OpenRC, then you must ***
*** reboot immediately using the following command:                ***
for file in /etc/rc0.d/K*; do s=`basename $(readlink "$file")` ; /etc/init.d/$s stop; done
**********************************************************************
while APT tried to replace "sysv-rc" by "openrc". I did so but the update didn't work and it remains in the update queue. I've also found that the follwing packages are kept back:

Code:
zfs-initramfs zfs-zed zfsutils-linux
But this is not too important for me as I don't use ZFS on these nodes.

How to fix this?

TIA
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!