Unstimmigkeiten bei Update-Vorbereitungen zu PVE 6.0

Diani

Member
Sep 20, 2019
7
0
6
23
Hallo,

ich möchte von PVE 5.4 auf 6.0 auf einem Debian Linux/Stretch updaten. Mich irriert das hier
# pve5to6
= CHECKING VERSION INFORMATION FOR PVE PACKAGES =

Checking for package updates..
PASS: all packages uptodate

Checking proxmox-ve package version..
PASS: proxmox-ve package has version >= 5.4-2

Checking running kernel version..
PASS: expected running kernel '4.15.18-20-pve'.

= CHECKING CLUSTER HEALTH/SETTINGS =

SKIP: standalone node.

= CHECKING HYPER-CONVERGED CEPH STATUS =

SKIP: no hyper-converged ceph setup detected!

= CHECKING CONFIGURED STORAGES =

PASS: storage 'local' enabled and active.
PASS: storage 'zp_100' enabled and active.

= MISCELLANEOUS CHECKS =

INFO: Checking common daemon services..
PASS: systemd unit 'pveproxy.service' is in state 'active'
PASS: systemd unit 'pvedaemon.service' is in state 'active'
PASS: systemd unit 'pvestatd.service' is in state 'active'
INFO: Checking for running guests..
WARN: 4 running guest(s) detected - consider migrating or stopping them.
INFO: Checking if the local node's hostname 'neckar' is resolvable..
INFO: Checking if resolved IP is configured on local node..
FAIL: Resolved node IP 'xxx.xxx.xxx.66' not configured or active for 'neckar'
INFO: Check node certificate's RSA key size
PASS: Certificate 'pve-root-ca.pem' passed Debian Busters security level for TLS connections (4096 >= 2048)
PASS: Certificate 'pve-ssl.pem' passed Debian Busters security level for TLS connections (2048 >= 2048)
INFO: Checking KVM nesting support, which breaks live migration for VMs using it..
PASS: KVM nested parameter set, but currently no VM with a 'vmx' or 'svm' flag is running.

= SUMMARY =

TOTAL: 15
PASSED: 11
SKIPPED: 2
WARNINGS: 1
FAILURES: 1
Der Hostname steht in der /etc/hosts drin und ist auch anpingbar.

Dann, ist von Stretch ein Upgrade von PVE 5.4 nach 6.0 überhaupt möglich, oder ist das Systemupgrade nach Buster Voraussetzung? Bzw. liefe PVE 5.4 auch noch unter Debian Buster? Ich frage, weil ich ein instabiles System vermeiden will.

Vielen Dank für eure Antworten
Diani
 
Last edited:
bitte mal folgendes in code tags posten:
* `cat /etc/hosts`
* `ip a`
* `uname -n`
* `hostname -f`
 
Code:
# cat /etc/hosts
127.0.0.1       localhost
xxx.xxx.xxx.a6   neckar.example.tdl      neckar

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
Code:
# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp49s0f0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ac:1f:6b:26:70:78 brd ff:ff:ff:ff:ff:ff
3: enp49s0f1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ac:1f:6b:26:70:79 brd ff:ff:ff:ff:ff:ff
4: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr0 state UP group default qlen 1000
    link/ether ac:1f:6b:62:15:68 brd ff:ff:ff:ff:ff:ff
5: eno2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ac:1f:6b:62:15:69 brd ff:ff:ff:ff:ff:ff
6: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ac:1f:6b:62:15:68 brd ff:ff:ff:ff:ff:ff
    inet xxx.xxx.xxx.66 peer xxx.xxx.xxx.yy/32 brd xxx.xxx.xxx.zzz scope global vmbr0
       valid_lft forever preferred_lft forever
    inet xxx.xxx.xxx.70/32 scope global vmbr0:mx
       valid_lft forever preferred_lft forever
    inet xxx.xxx.xxx.65/32 scope global vmbr0:apache2
       valid_lft forever preferred_lft forever
    inet xxx.xxx.xxx.84/32 scope global vmbr0:ns1
       valid_lft forever preferred_lft forever
    inet xxx.xxx.xxx.85/32 scope global vmbr0:ns2
       valid_lft forever preferred_lft forever
    inet6 fe80::ae1f:6bff:fe62:1568/64 scope link
       valid_lft forever preferred_lft forever
7: vmbr1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 2a:75:fe:70:b4:14 brd ff:ff:ff:ff:ff:ff
    inet xxx.xxx.xxx.66/24 brd 192.168.1.255 scope global vmbr1
       valid_lft forever preferred_lft forever
    inet6 fe80::f4ae:4bff:fe54:aac0/64 scope link
       valid_lft forever preferred_lft forever
9: tap101i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr1 state UNKNOWN group default qlen 1000
    link/ether 2a:75:fe:70:b4:14 brd ff:ff:ff:ff:ff:ff
10: tap102i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr1 state UNKNOWN group default qlen 1000
    link/ether 3a:0d:4b:8c:ad:c8 brd ff:ff:ff:ff:ff:ff
11: tap103i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr1 state UNKNOWN group default qlen 1000
    link/ether 1e:50:df:43:c2:e5 brd ff:ff:ff:ff:ff:ff
16: tap100i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr1 state UNKNOWN group default qlen 1000
    link/ether 42:56:53:c4:7e:3c brd ff:ff:ff:ff:ff:ff

Code:
# uname -n
neckar

Code:
# hostname -f
neckar.example.tdl
 
Last edited:
Danke Stoiko,
so wirklich hilft das nicht weiter. Denn zum Einen bieten die Links keine wirkliche Lösung an. Und zum Anderen habe ich in meiner /etc/network/interfaces keine CIDR-Notation gemacht, sondern ganz normale Schreibweise:
Code:
auto vmbr0
iface vmbr0 inet static
        address  xxx.xxx.xxx.66
        netmask  255.255.255.192
        gateway  xxx.xxx.xxx.65
        pointopoint xxx.xxx.xxx.65
        addresses-apache2 xxx.xxx.xxx.75
        addresses-ns1 xxx.xxx.xxx.84
        addresses-ns2 xxx.xxx.xxx.85
        addresses-mx xxx.xxx.xxx.70
        bridge-ports eno1
        bridge-stp off
        bridge-fd 0
        dns-nameserver 9.9.9.9
        create_alias_devices yes
        label_addresses yes

Das ist also noch ein ungelöstes Problem. Was macht denn das Perl-Script "pve5to6" sonst noch? Brauchen wir das unbedingt für ein Upgrade von 5.4 nach 6.0?

Dann hatte ich ja auch noch die Frage gestellt, ob PVE 5.4 auch unter Debian Linux "Buster" lauffähig wäre. Ich muss jetzt nicht sofort nach PVE 6.0 upgraden. Ein Systemupgrade wäre allerdings schon sinnvoll.

Vielen Dank

Diani
 
so wirklich hilft das nicht weiter. Denn zum Einen bieten die Links keine wirkliche Lösung an. Und zum Anderen habe ich in meiner /etc/network/interfaces keine CIDR-Notation gemacht, sondern ganz normale Schreibweise:
sorry - hätte ich etwas klarer formulieren können: Der bugreport besagt, dass pve5to6 nicht alle Netzwerkkonfigurationen korrekt erkennt und tw. sagt etwas sei nicht in Ordnung, obwohl es korrekt konfiguriert ist (auf den ersten Blick scheint bei der geposteten Konfiguration alles soweit zu stimmen und diese Fehlermeldung von pve5to6 kann ignoriert werden).

Andererseits habe ich bisher noch die directives 'create_alias_devices', 'label_addresses' und 'addresses-*' noch nicht in einer /etc/network/interfaces gesehen - nach kurzem googlen habe ich nur folgendes gefunden: http://wertarbyte.de/debian/ifupdown/addresses

Wurde das script selbst nachinstalliert, oder kommt das über ein Debian-paket rein (welches?) ? - Würde uns helfen beim Einschätzen, ob diese Config häufig verwendet wird.

Das ist also noch ein ungelöstes Problem. Was macht denn das Perl-Script "pve5to6" sonst noch? Brauchen wir das unbedingt für ein Upgrade von 5.4 nach 6.0?
Das script ist eine Checklist, die häufig vorkommende Probleme beim Upgrade erkennt und User vorwarnt, damit die Configs vor dem Upgrade noch in Ordnung gebracht werden kann. Es selbst nimmt keine Veränderungen am System vor.

Dann hatte ich ja auch noch die Frage gestellt, ob PVE 5.4 auch unter Debian Linux "Buster" lauffähig wäre. Ich muss jetzt nicht sofort nach PVE 6.0 upgraden. Ein Systemupgrade wäre allerdings schon sinnvoll.

PVE ist sehr eng mit der jeweiligen Debian-version verknüpft - sprich das Upgrade stretch->buster ist auch gleich das upgrade PVE 5.4-> PVE6.0
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!