Unmet dependency for backup client in Linux Mint 21

Jul 20, 2022
60
2
8
I am testing the newest release of Linux Mint 21. Attempting to install proxmox-backup-client:
Code:
root@elmer:/home/dan# apt-get install proxmox-backup-client
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 proxmox-backup-client : Depends: libssl1.1 (>= 1.1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

The Linux Mint repositories are as follows:
Code:
deb http://packages.linuxmint.com vanessa main upstream import backport #id:linuxmint_main

deb http://archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse

And here is the Proxmox client repository:
Code:
deb http://download.proxmox.com/debian/pbs-client bullseye main

Code:
root@elmer:/home/dan# apt search libssl
p   libssl-dev                                             - Secure Sockets Layer toolkit - development files                 
p   libssl-dev:i386                                        - Secure Sockets Layer toolkit - development files                 
p   libssl-doc                                             - Secure Sockets Layer toolkit - development documentation         
v   libssl-doc:i386                                        -                                                                 
p   libssl-ocaml                                           - OCaml bindings for OpenSSL (runtime)                             
v   libssl-ocaml-aifn8                                     -                                                                 
p   libssl-ocaml-dev                                       - OCaml bindings for OpenSSL                                       
v   libssl-ocaml-dev-aifn8                                 -                                                                 
p   libssl-utils-clojure                                   - library for SSL certificate management on the JVM               
i   libssl3                                                - Secure Sockets Layer toolkit - shared libraries                 
p   libssl3:i386                                           - Secure Sockets Layer toolkit - shared libraries

So, there is a new release of Ubuntu called jammy. But there doesn't seem to be support in the Proxmox client for the updated libssl3 library. Do you have any plans for this?

Thanks!
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
17,137
533
133
Austria
www.proxmox.com

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!