Unbound / systemd-resolved

KatyComputer

Active Member
Sep 26, 2019
192
16
38
61
St Louis
katycomputer.com
I have my PVE box configuring using the Routed configuration. Everything was going well until I decided to install Unbound on eno1. Curiously, I had no trouble running PowerDNS Recursor on eno1.

Unbound wouldn't start, I did some digging and learned systemd-resolved was listening on port 53, so I executed systemctl disable systemd-resolved --now, this allowed unbound to start, but caused eno1 to stop routing packets to vmbr0

Urgh #@@%@#!!

After several hours of research, found the solution, I edited /etc/systemd/resolved.conf:
[Resolve]
DNS=127.0.0.1
FallbackDNS=1.0.0.1
MulticastDNS=no
DNSStubListener=no

Then ran: systemctl enable systemd-resolved --now

All is now well. Anyone know why systemd-resolved is required for routing, or why everything works fine with pdns? In any event, I hope this helps someone.
 
All is now well. Anyone know why systemd-resolved is required for routing, or why everything works fine with pdns? In any event, I hope this helps someone.

It shouldn't be, also here I do not use systemd-resolved at all:
Code:
systemctl status systemd-resolved.service 
● systemd-resolved.service - Network Name Resolution
   Loaded: loaded (/lib/systemd/system/systemd-resolved.service; disabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/systemd-resolved.service.d
           └─resolvconf.conf
   Active: inactive (dead)

So something else pulled it in...
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!