[SOLVED] Unable to Send mail but can receive

Astraea

Active Member
Aug 25, 2018
165
20
38
I have setup PMG and currently, have a domain configured (techbehave.com) with GoDaddy with the following records.
A -> @ -> Public IP Address
A -> * -> Public IP Address

MX -> mail.techbehave.com -> 10
MX -> mail.techbehave.com -> 20

I then have my PFSense firewall configured to port forward port 25 to PMG which is at 10.42.58.111. I have a Modoboa email server running (I have also tried with mailcow) at 10.42.58.235 which is set in PMG at the transport for the techbehave.com domain. I can send a test email to myself from is my email working and I received the email but when I try and reply the email is sent to PMG which is both test email server was set to send all mail to PMG. The email is accepted by PMG but then deferred saying that techbehaved.com (Public IP:25) timed out

I am clearly missing something on the PMG side but not sure what it is. If you need more details please let me know, I have been working to get an email server up for the last 2 days now and not sure what else to try.
 
Last edited:

Astraea

Active Member
Aug 25, 2018
165
20
38
A follow up to this is that I can send email to a domain that is not managed by PMG such as a shaw email address. Is there something I have to do to have it work with domains that are passing through PMG?
 

Astraea

Active Member
Aug 25, 2018
165
20
38
I am not sure what changed between my testing setup on Virtualbox and my production install on ProxmoxVE but everything is working now.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!