[SOLVED] Unable to restore backup piped over ssh


Renowned Member
Sep 25, 2012

It was simply an uncompressed vma file. I did:

cat myfile.vma | qmrestore - 101
What follows is the original post.


On SERVER_A, I send a backup to SERVER_B like this:

vzdump 105 --stdout | ssh -p 25222 root@20ttt.ddns.net "cat - > /var/lib/vz/dump/vzdump-qemu-115-octavio.vma.gz"

However, on the other side, I'm not able to extract the file. Whether it is a .gz or a .lzo, i get an error similar to:

TASK ERROR: command 'set -o pipefail && zcat /var/lib/vz/dump/vzdump-qemu-115-octavio.vma.gz | vma extract -v -r /var/tmp/vzdumptmp6405.fifo - /var/tmp/vzdumptmp6405' failed: got timeout
I've also tried renaming the file to .lzo and I've updated to the latest Proxmox. Neither helps. I'm not able to determine the type of compression used:

# file vzdump-qemu-115-octavio.vma.lzo
vzdump-qemu-115-octavio.vma.lzo: data

... but I assume it is whatever the default is.

I can see what appears to be my <vmid>.conf file and a block device image in the file:

# head -n 20 vzdump-qemu-115-octavio.vma.lzo
VMAuu��G��(��p.\u�M���Tr`+_�.*�0o2_(qemu-server.confIballoon: 4096
boot: cdn
bootdisk: virtio0
cores: 12
memory: 6144
name: POR
net1: virtio=4A:D8:A6:39:41:77,bridge=vmbr0
numa: 0
onboot: 1
ostype: win7
sockets: 1
virtio0: local-zfs:vm-105-disk-2,cache=writeback,size=160G
virtio1: tank:vm-105-disk-3,backup=0,cache=writeback,size=250G
���� !"#$%&'()*+,-./01234567893м|�ؾ|����Ph�����~|
������VU���A��U�]r���u �t�f`�~t&fhfhh|hh�B�V���������|�V�v�N�n�fas�u
�~������2��]랁>�U�un��u�����`���d����f#�;f��CPAu2��r,fh�fhffSfSfUfhfh|fah�Z2�|���������2������ !� �������d�$�$�nvalid partition tableError loading operating systemMissing operating systemc{�

��(�U���NTFS �?���U!��;T�;T��м|��hfˈf�>NTFSu�A��U�r
uۣ�Z3۹ +�����+����f#�-f��CPAu$��rh�hph fSfSfUh�fa�3?(�������f`f�ffhfPShh�B���fY[ZfYfY�f���u�faà���������t �����
A disk read error occurred
BOOTMGR is missing
BOOTMGR is compressed
Press Ctrl+Alt+Del to restart

Thanks in advance.
Last edited:
it seems you do not use any compression, so you use cat instead of zcat and the 'vma' extension instead of 'vma.gz'


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!