Unable to remove datastore in PBS

Mirmanium

Member
Aug 14, 2020
60
8
13
44
Hi super community,

I am unable to remove a datastore which are no longer available physically. The problem comes when executing the command:
Code:
proxmox-backup-manager datastore remove NameOfTheDatastore

and throws
TASK ERROR: datastore is currently in use

If I use the GUI button "Remove Datastore", the Tasks end throwing above message too.

Something I tried was to change the Maintenance mode of this disk to value "Offline" and I get this message (not sure if can help to troubleshoot this problem):
1676928763663.png

I am unable to find the "60" conflicting active tasks, these does not appear in the Tasks button.
What can I do to force "not in use" anymore?

Thank you,
 
Last edited:
Have you tried restarting the proxmox-backup and proxmox-backup-proxy services?

Code:
systemctl restart proxmox-backup.service
systemctl restart proxmox-backup-proxy.service
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!