[SOLVED] Unable to boot after Proxmox Installation (ZFS)


Well-Known Member
Mar 12, 2013
Hi there,

I currently have 3 working Proxmox Nodes on various OVH dedicated servers, all working well. New one (ADVANCE-APAC) is not playing nice though. After installing over IPMI, utilising ZFS and raid1 (2 x 1.92TB SSD NVMe), it fails to boot stating there is no bootable media. Seemed like an issue with UEFI not playing nicely. Disabled UEFI and tried legacy, and still no luck. I'm sure this is something basic, but would appreciate any guidance.

Thanks in advance,
Not sure if it's helpful information, but when the installer has finished and I select to reboot the device, there are a bunch of SQUASHFS errors that show up (attached).

When trying to boot from the proxmox ISO, into recovery boot I get errors too (attached).


  • Screenshot 2023-06-15 at 12.38.29 pm.jpeg
    Screenshot 2023-06-15 at 12.38.29 pm.jpeg
    619.2 KB · Views: 9
  • Screenshot 2023-06-15 at 10.11.56 am.jpeg
    Screenshot 2023-06-15 at 10.11.56 am.jpeg
    468.1 KB · Views: 7
SOLVED: Okay- I had to disable CSM, and then ensure that M.2 and/or pcie were set to disable legacy mode, rather than "auto" mode. After that, the installer picked up that it was an EFI boot, and everything working beautifully. Hope this helps someone else!

  • Like
Reactions: SimoneGiacomelli


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!