Unable to assign network bridge to VM (missing permission?)

SebastianH

Member
Sep 16, 2020
2
0
6
39
Hello all,

I have created a new user "Test" which belongs to the group "TechnicalAdmin". This group was added to a resource pool "TST" and given these permissions:

1698927444220.png

As user "Test" I can create a VM, access the ISO storage, assign a specific storage to the VM disk, in short do everything I need to create and manage a VM in this pool, but I cannot add a Linux bridge to the VM. (see screenshot below)

1698927345605.png

Am I missing any further permissions for this or have I not taken something else into account? I use Proxmox 8.0.4. btw.

Many thanks in advance!

Greetings Sebastian
 
At first glance it does look good, but could you pls print the paths as well as they could be the reason
 
AFAICT you'd have to create a permission for PATH:/vms with SDN.Use, SDN.Allocate and SDN.Audit to be able to see and use existing SDN settings (bridges etc.) when creating a new VM.
Your current permission set only allows to change settings von the vms [100,102,103] and all the vms in the /pool/TST (and all the vms in /storage/local and /storage/pve01-local-storage)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!