Unable to assign guest own IP

NetNoob

New Member
Mar 25, 2019
2
0
1
35
Setup Proxmox on a dedicated server with the default bridged networking. Launched a CentOS container, can update packages and use it normally with the GUI shell, but I cannot connect to the container with the IP address I assigned it. Made sure the firewall's were off for testing, rebooted a couple times. I just don't know what I'm doing wrong.

My node's "/etc/network/interfaces"
Code:
auto lo
iface lo inet loopback

iface enp4s0 inet manual

iface enp5s0 inet manual

auto vmbr0
iface vmbr0 inet static
        address  x.x.x.234
        netmask  255.255.255.248
        gateway  x.x.x.233
        bridge-ports enp4s0
        bridge-stp off
        bridge-fd 0
My container settings
Code:
Name: eth0
Bridge: vmbr0
VLAN Tag: no VLAN
Firewall: Off
IPv4: Static
IPv4/CIDR: x.x.x.235/32
Gateway: x.x.x.233
What my host provided
Code:
Netmask : 255.255.255.248
 Gateway : x.x.x.233
 IP Address :
     - x.x.x.234
     - x.x.x.235
     - x.x.x.236
     - x.x.x.237
DNS Servers (Resolver Only): x.x.x.2, x.x.x.10
 
Actually, that config worked perfectly fine. Was able to install httpd to see if the default page would come up and it does. I guess it was just me trying to SSH into my container.

/thread
 
You have to enable ssh rights on container. Centos comes with ssh disabled by default. Actually today most distros do.
Also you need to do special config if you want to ssh with root.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!