[SOLVED] Unable to access web interface after updating certificate

niknotnick

New Member
Jul 19, 2023
2
0
1
Hi,

I am quite new to proxmox.

I tried updating the certificate through the UI and now the web UI is not loading. All services and VMs are up and running and I can access the server using SSH. Can someone please guide me to recover my setup? I have attached output for following commands.
  • pveversion -v
  • systemctl status pveproxy
  • systemctl status pvedaemon
 

Attachments

  • pvedaemon.txt
    1.1 KB · Views: 7
  • pveproxy.txt
    1.3 KB · Views: 6
  • pveversion.txt
    1.3 KB · Views: 4
What is the output when in one terminal you run: journalctl -f
and in the second: systemctl try-reload-or-restart pvedaemon pveproxy pvestatd pvescheduler

What is the output of : curl -sk https://localhost:8006 ?


Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
Thank you very much for getting back. I managed to resolve the issue after going through this. I renamed both pveproxy-ssl.pem and pveproxy-ssl.key. After restarting the VE, I can now access the web UI.
 
Hello, please don't forget to mark your issue as solved so other users can use it as a reference :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!