Unable to access Synology NFS share in Proxmox "status: unknown"

a5pire

New Member
Sep 12, 2019
10
0
1
14
Hi all,

I'd really appreciate some help here. I had a working NFS share but needed to change the VLAN Proxmox sat on so as a result the IP address changed. Now I am unable to mount the NFS share at all. The Synology NAS sits on a different VLAN to Proxmox so I'm unsure if this changes whether or not this is at all possible.

I have updated the Synology NFS permissions:
Code:
Client: 192.168.107.100 (new proxmox ip address)
Privilege: Read/Write
Squash: Map all users to admin
Async: yes
Allow Non Privileged ports: yes (ports higher than 1024)
Allow users to access mounted subfolders: yes
The NFS section of the /etc/pve/storage.cfg file looks like this:
Code:
nfs: plex-media
        export /volume1/media
        path /mnt/pve/plex-media
        server 192.168.0.152
        content backup
        maxfiles 3

nfs: backups
        export /volume1/storage/tim/source/hypervisor/backups
        path /mnt/pve/backups
        server 192.168.0.152
        content iso,snippets,backup,rootdir,vztmpl,images
        maxfiles 3
time pvesm nfsscan 192.168.0.152 (ip of synology server) returns command '/sbin/showmount --no-headers --exports 192.168.0.152' failed: exit code 1

I can ping devices from proxmox that reside on the other VLAN but can not ping the synology nas.

This all seems to point towards a permissions issue however the permissions are fine on the synology side (as detailed above) and it all worked before I changed the VLAN. I have tried removing permissions and recreating them, removing all NFS shares from proxmox and recreating them via the commandline and via the GUI. I have tried creating the share with different NFS versions, with and without the nolock option but nothing seems to work.

Is this all because Proxmox is on a different VLAN to the Synology?

EDIT: comments about ping
 
Last edited:

Richard

Proxmox Staff Member
Staff member
Mar 6, 2015
799
32
48
Austria
time pvesm nfsscan 192.168.0.152 (ip of synology server) returns command '/sbin/showmount --no-headers --exports 192.168.0.152' failed: exit code 1

I can ping devices from proxmox that reside on the other VLAN but can not ping the synology nas.
Looks like a not properly configured network. For considering details it is necessary to know the network topology as well as the network configuration in Proxmox, run e.g.
Code:
ip addr
cat /etc/network/interfaces
in the Proxmox host.
 

a5pire

New Member
Sep 12, 2019
10
0
1
14
Thanks so much for the reply. Hopefully this should provide the necessary information.

Topology:

I have one internet connection utilised by 3 networks passing through a Unifi USG and 24 port switch.
Default Network: 192.168.0.0/24 the USG address is 192.168.0.1 and the switch address is 192.168.0.2
Guest Network: vlan10 192.168.10.0/24
IoT Network: vlan107 192.168.107.0/24

As I understand, vlans are all separate by default and devices shouldnt be able to talk to each other unless firewall rules allow it. So far I haven't created any firewall rules. With this in mind, I have proxmox with an address of 192.168.107.100 and 3 other VMs running in proxmox 192.168.107.15, 192.168.107.130, 192.168.107.50. All the VMs (and proxmox) can ping each other IoT Network and other devices on the Default Network. None of them however, can ping the Synology NAS (the location of the NFS shares). Its address is 192.168.0.152. I have disabled the NAS firewall for testing but this has made no difference.

ip addr
Code:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP group default qlen 1000
    link/ether 54:b2:03:19:e8:33 brd ff:ff:ff:ff:ff:ff
3: eno1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP group default qlen 1000
    link/ether 54:b2:03:19:e8:32 brd ff:ff:ff:ff:ff:ff
4: wlp6s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether a0:a4:c5:8a:41:e3 brd ff:ff:ff:ff:ff:ff
5: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue master vmbr0 state UP group default qlen 1000
    link/ether 54:b2:03:19:e8:32 brd ff:ff:ff:ff:ff:ff
6: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 54:b2:03:19:e8:32 brd ff:ff:ff:ff:ff:ff
    inet 192.168.107.100/24 brd 192.168.107.255 scope global vmbr0
       valid_lft forever preferred_lft forever
    inet6 fe80::56b2:3ff:fe19:e832/64 scope link
       valid_lft forever preferred_lft forever
7: tap100i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UNKNOWN group default qlen 1000
    link/ether d2:13:94:4a:3c:13 brd ff:ff:ff:ff:ff:ff
8: tap201i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master fwbr201i0 state UNKNOWN group default qlen 1000
    link/ether ea:93:fe:cb:cd:4c brd ff:ff:ff:ff:ff:ff
9: fwbr201i0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 92:f4:a5:ce:ee:c1 brd ff:ff:ff:ff:ff:ff
10: fwpr201p0@fwln201i0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master vmbr0 state UP group default qlen 1000
    link/ether 26:d5:c0:89:cb:fb brd ff:ff:ff:ff:ff:ff
11: fwln201i0@fwpr201p0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master fwbr201i0 state UP group default qlen 1000
    link/ether 92:f4:a5:ce:ee:c1 brd ff:ff:ff:ff:ff:ff
12: tap202i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master fwbr202i0 state UNKNOWN group default qlen 1000
    link/ether a6:a5:59:d1:13:2f brd ff:ff:ff:ff:ff:ff
13: fwbr202i0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether d2:84:ff:10:e5:81 brd ff:ff:ff:ff:ff:ff
14: fwpr202p0@fwln202i0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master vmbr0 state UP group default qlen 1000
    link/ether ee:a2:72:7f:5d:24 brd ff:ff:ff:ff:ff:ff
15: fwln202i0@fwpr202p0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master fwbr202i0 state UP group default qlen 1000
    link/ether d2:84:ff:10:e5:81 brd ff:ff:ff:ff:ff:ff
cat /etc/network/interfaces
Code:
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual

auto enp5s0
iface enp5s0 inet manual

auto bond0
iface bond0 inet manual
        bond-slaves eno1 enp5s0
        bond-miimon 100
        bond-mode balance-alb

auto vmbr0
iface vmbr0 inet static
        address  192.168.107.100
        netmask  24
        gateway  192.168.107.1
        bridge-ports bond0
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 2-4094
Thanks so much again for taking a look at this!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!