[SOLVED] Unable to acces console with no vnc


New Member
May 13, 2019

I have some issue accessing the console under pve, no vnc mostly fail to start..
I reinstalled proxmox, same problem. I also tried to connect with different pc and different internet browsers, without any success.

I haven't any issue in ssh, with putty or ilo console(HP server).

I have this line in syslog when no vnc fail to start:

May 20 12:39:41 home pvedaemon[1471]: Use of uninitialized value $shellcmd in exists at /usr/share/perl5/PVE/API2/Nodes.pm line 714.
May 20 12:39:41 home pvedaemon[1471]: <root@pam> starting task UPID:home:0000133E:00036DE8:5CE283ED:vncshell::root@pam:
May 20 12:39:41 home pvedaemon[4926]: starting termproxy UPID:home:0000133E:00036DE8:5CE283ED:vncshell::root@pam:
May 20 12:39:51 home pvedaemon[4926]: command '/usr/bin/termproxy 5901 --path /nodes/home --perm Sys.Console -- /bin/login -f root' failed: exit code 4
May 20 12:39:51 home pvedaemon[1471]: <root@pam> end task UPID:home:0000133E:00036DE8:5CE283ED:vncshell::root@pam: command '/usr/bin/termproxy 5901 --path /nodes/home --perm Sys.Console -- /bin/login -f root' failed: exit code 4

Any idea?

Please post the output of:
# pveversion -v

Update: Without knowing your version, I assume it's not the newest. This issue should be resolved in an up2date installation.
Last edited:
This was fixed with pve-manager: 5.4-5


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!