Trying to pve-zsync VMs and Containers

Thierry PROST

New Member
Dec 7, 2018
Hello there!

I'm trying to backing up my VMs, containers (linked for some) and templates from my current server which is going to be replaced by a better one.

I had problem before trying to create a cluster and add a node (because of the hostname that are the same on the two machines) and found pve-zsync is an elegant solution for this (as well for redundant backup solution).

The problem I face is:

root@noxen:~# pve-zsync sync --source 100 --dest --verbose
full send of rpool/basevol-100-disk-1@rep_default_2018-12-07_14:56:41 estimated size is 1.11G
total estimated size is 1.11G
zfs send -v -- rpool/basevol-100-disk-1@rep_default_2018-12-07_14:56:41 | ssh -o 'BatchMode=yes' -- zfs recv -F -- rpool/basevol-100-disk-1
Host key verification failed.

Browsing few posts on forums, anything I tried was with no luck. Things I tried are:
- pvecm updatecerts and restart pveproxy service on both servers
- ssh -o 'HostKeyAlias=<Target node Name>' root@<Target node IP> on both servers
- delete /root/.ssh/know_hosts on both server

Nothing worked, still stuck with same error.

Can you help me to sort this out ?

Thanks anyway.
Do a ssh login from both nodes to each other, there you should get the question if you want to add the host key. As pve-zsync runs over ssh, there can't be any prompts when connecting.
Thanks for your answer Alwin!

I connected on both servers to each other, I had the question: ECDSA key fingerprint is SHA....
Then ctrl+d to delog and if I try just after to use pve-zsync, I got this time:

Permission denied (publickey,password)

I also tried to execute zsync from new server:

root@noxen:~# pve-zsync sync --source --dest rpool --verbose's password:'s password:'s password:'s password:'s password:'s password:
Permission denied (publickey,password).'s password:
ssh -o 'BatchMode=yes' root@x.x.x.x.x -- zfs send -v -- rpool/basevol-100-disk-1@rep_default_2018-12-07_16:26:31 | zfs recv -F -- rpool/basevol-100-disk-1
cannot receive: failed to read from stream

I don't know why it asks multiple time the password, which is correct. I've got no problems using regular ssh connection between both servers.

Anything else to do pair publickey and password together and get rid of this ?

Thanks again!
Last edited:
As I said, there can't be any prompts. The ssh connection needs to happen with key authentication (no passphrase; try with ssh-copy-id), only when you can login without any prompts appearing, then pve-zsync will work.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!