Trying out proxmox and getting error that isn't letting me test it.

fidgetbytes

New Member
Aug 12, 2023
1
0
1
Hi there,

I am trying out proxmox, and I used the installer ISO and got no errors during installation.

So I tried to test out a CT templates from images.linuxcontainers.org and downloading the rootfs.tar.xz and I set it up. One the CT is made I get a following error every time, and I don't know why.

Code:
failed waiting for client: timed out
TASK ERROR: command '/usr/bin/termproxy 5900 --path /vms/100 --perm VM.Console -- /usr/bin/dtach -A /var/run/dtach/vzctlconsole100 -r winch -z lxc-console -n 100 -e -1' failed: exit code 1

Can anyone shed any light on why I am getting this error?
Thanks
 
If this is your first contact with PVE you might try to use the official templates - there are some dozen available. They need to be downloaded first; usually via <node> -- > "local" datastore --> "CT Templates" --> "Templates"

Have fun!
PS: welcome to the club :)
 
What UdoB said. But I think you have to enter "pveam update" in a terminal first, to populate the list (and periodically to find new images.) At least, if that's in the UI, I don't know where.

After downloading a template as UdoB described, it should be available when creating a container when you get to the "Template" tab.

But fidgetbytes, I have a question, how did you download from images.linuxcontainers.org? I see a list there, but no links.

Anyway, from the name of the file you described, rootfs.tar.xz, sounds like it may be an archive of a filesystem, not an LXC container image, and if so that's why LXC can't start it.***

*** OK, I'm wrong, I couldn't figure out how to download directly from the site but on a non-Proxmox machine I ran lxc-create to download one then looked in /var/cache/lxc/download and there is indeed a rootfs.tar.xz under the folder for the distro I used. But still don't know if that will work in Proxmox (but I'm about to try it.)

Hmm, it worked. This was Arch Linux. What distro did you try, fidgetbytes?

AHA, the link for downloads is https://images.linuxcontainers.org/images/ but for some reason that link isn't on the main page. (I found it in a post on another site.)
 
Last edited:
Is this documented?

Code:
failed waiting for client: timed out
TASK ERROR: command '/usr/bin/termproxy 5900 --path /nodes/$node --perm Sys.Console -- /bin/login -f root' failed: exit code 1
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!