Trunk port configuration

Leo David

Member
Apr 25, 2017
75
1
13
41
Hello,
I pretty have a hard time to get port trunking properly working. I've followed the tutorial, but no arp is coming on the interface for a specific vlan. Below, what i have configured, maybe i habve missed something to configure:

# network interface settings
auto lo
iface lo inet loopback
iface eth0 inet manual
iface eth1 inet manual

auto bond0
iface bond0 inet manual
slaves eth0 eth1
bond_miimon 100
bond_mode 4

auto bond0.5
iface bond0.5 inet manual
vlan-raw-device bond0

auto bond0.6
iface bond0.6 inet manual
vlan-raw-device bond0

auto vmbr0
iface vmbr0 inet static
address 10.10.6.118
netmask 255.255.255.0
gateway 10.10.6.254
bridge_ports bond0.6
bridge_stp off
bridge_fd 0
auto vmbr1
iface vmbr1 inet static
address 10.10.5.118
netmask 255.255.255.0
bridge_ports bond0.5
bridge_stp off
bridge_fd 0

Then, i have configured a VM'network settings with: "Bridged mode", "VLAN Tag:5", "Bridge: vmbr1".
But no layer2 traffic...

- Do you think this configuration should be fine and working ?
- Should "VLAN aware" be checked in vmbr1 settings ?
- Is really needed for vmbr1 to have an ip address configured ?

Thank you very much,

Have a nice day !
 

Alwin

Proxmox Staff Member
Staff member
Aug 1, 2017
4,320
397
88
- Do you think this configuration should be fine and working ?
If it would be ok, then it would work, wouldn't it? ;)
- Should "VLAN aware" be checked in vmbr1 settings ?
You can ease your setup by using a vlan_aware bridge and skip the configuration of vlans on the bond.
- Is really needed for vmbr1 to have an ip address configured ?
No. We create the first bridge and set it during install, for convenience.

Example network settings (top of my head):
Code:
# network interface settings
auto lo
iface lo inet loopback
iface eth0 inet manual
iface eth1 inet manual

auto bond0
iface bond0 inet manual
slaves eth0 eth1
bond_miimon 100
bond_mode 4

auto vmbr0
iface vmbr0 inet static
address 10.10.6.118
netmask 255.255.255.0
gateway 10.10.6.254
bridge_ports bond0
bridge_vlan_aware yes
bridge_stp off
bridge_fd 0
Then set this on the network config tab of the VM:
Then, i have configured a VM'network settings with: "Bridged mode", "VLAN Tag:5", "Bridge: vmbr0".
 

Leo David

Member
Apr 25, 2017
75
1
13
41
Thank you very much !
:) yes, this: "Do you think this configuration should be fine and working ?" was like o_O

I'll try reconf as per your recomendations, and get back.
Thank you very much again !
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!