Trouble restoring LXC/CT from PBS

Jan 24, 2020
28
3
23
38
Due to a mistake on my part, I need to restore a LXC container from a backup. I have some snapshots in PBS and I know they work because in PBS I can browse files and restore from there. I tried through the UI from the stopped container, but it errored out stating that it can't find the disk file. I don't have the exact error message.

Then I ran
Code:
proxmox-backup-client snapshot list --repository 192.168.1.16:backup
to get the list of snapshots, and taking the snapshot I wanted to restore I ran
Code:
pct restore 303 192.168.1.16:backup/ct/303/2023-09-03T18:00:46Z -storage nvme1tb --unprivileged 1

This returns
Code:
recovering backed-up configuration from '192.168.1.16:backup/ct/303/2023-09-03T18:00:46Z'
unable to restore CT 303 - can't find file '192.168.1.16:backup/ct/303/2023-09-03T18:00:46Z'

Do I have the syntax wrong or what can I do to move forward?
 
Hello,

use the name/id you gave the backup-server in the pve storage configuration instead of the ip address with pct.
 
Thanks, that worked for me! I wasn't able to determine that from the documentation, but I changed from the IP address to the name of the backup target which in my case is "backup"
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!