Transports behaviour

Discussion in 'Mail Gateway: Installation and configuration' started by RichardTW, Jan 9, 2019.

  1. RichardTW

    RichardTW New Member

    Joined:
    Jan 9, 2019
    Messages:
    3
    Likes Received:
    0
    Hi all

    I have added a transport rule for one domain to send mail to a seperate server than our default relay, this is actually the same IP as our normal mailserver but an alternative port.

    I have two issues;
    - PMG shows " Recipient address rejected: unverified address: connect to 192.168.222.253[192.168.222.253]:40025: Connection refused;" although we never see PMG make a connection to our mailserver (192.168.222.253) and this is possible via telnet from the PMG VM.
    - When I try to change the transport rule, the old rule continues to be used, for example I want to now test this transport rule against our other server which is on port 25, but PMG keeps trying to send to 40025. We see the /etc/pmg/transport file updated with the new information but it seems as though this is not used and PMG is working off a cache or similar.

    Can anyone confirm similar issues / advise me on what next steps may be?

    Thanks in advance
     
  2. RichardTW

    RichardTW New Member

    Joined:
    Jan 9, 2019
    Messages:
    3
    Likes Received:
    0
    Just a little more information.

    My first point above is now resolved somewhat, it seems to have been due to an initial test being rejected because email address did not exist. PMG seems to have remembered this email does not exist rather than checking again (it now does exist). Is there a cache somewhere I need to clear?

    Second issue with being unable to adjust the transport rule remains.

    Thanks
     
  3. Stoiko Ivanov

    Stoiko Ivanov Proxmox Staff Member
    Staff Member

    Joined:
    May 2, 2018
    Messages:
    567
    Likes Received:
    45
    regarding the rejection because the e-mail did not exist - it seems you have enabled recepient verification - The behaviour is documented in:
    http://www.postfix.org/ADDRESS_VERIFICATION_README.html and in `man 8 verify`
    the default settings (which pmg also uses) is to try once every 3h for negative results.
    In case you need to "flush" expire the cache, you can delete the cache-file and restart postfix (while also losing the other verification results )

    Hope this helps
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. RichardTW

    RichardTW New Member

    Joined:
    Jan 9, 2019
    Messages:
    3
    Likes Received:
    0
    Thank you Stoiko that explains this entirely.

    We ended up not needing to adjust transport rule, but this remains an issue it seems. Will open a bug report if issue remains on a new install.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice