[SOLVED] Tracking-Center - No data in database

Nov 5, 2019

We are using PMG v5.7-2 with the latest patches. Unfortunately the "Tracking-Center" outputs only "No data in database". The "Use advanced statistics filters" is set to "Yes".

The corresponding cli command, pmg-log-tracker, delivers also no output.

But strace -e -trace=open,read, shows that pmg-log-tracker opens /var/log/syslog and reads its content.

Thanks in advance.
Hi Stoiko.

Thx, for your fast reply.

Yes, mai.log is included in syslog.
Yes, the rotated files also contains the mail.log

No, I have not adapted the logrotate snippet and we are still using 5.x (5.7).
        rotate 7
                invoke-rc.d rsyslog rotate > /dev/null


example syslog excerpt:
2019-11-05T20:18:44.480340+01:00 mx1 postfix/cleanup[20311]: 63FA93C13E8: message-id=<PATT3L145_19013801_V3F9cSi2y6WUHN/znCTemw==.8A66@webgride111.slgnt.de>
2019-11-05T20:18:44.525687+01:00 mx1 postfix/qmgr[14817]: 63FA93C13E8: from=<message@my.zalando.at>, size=77918, nrcpt=1 (queue active)
2019-11-05T20:18:46.636344+01:00 mx1 postfix/smtpd[20114]: connect from localhost.localdomain[]
2019-11-05T20:18:46.637781+01:00 mx1 postfix/smtpd[20114]: 9BAD03C1572: client=localhost.localdomain[], orig_client=webgride111.slgnt.de[]
2019-11-05T20:32:15.384389+01:00 mx1 pmg-smtp-filter[19698]: 3C13E85DC1CE3D1394E: processing time: 2.302 seconds (2.281, 0.013, 0)
2019-11-05T20:32:15.384800+01:00 mx1 pmg-smtp-filter[19419]: 3C15725DC1CE3D9090F: processing time: 1.79 seconds (1.768, 0.014, 0)
2019-11-05T20:32:21.946462+01:00 mx1 pmg-smtp-filter[21561]: 2019/11/05-20:32:21 CONNECT TCP Peer: "[]:44998" Local: "[]:10024"
2019-11-05T20:32:21.998196+01:00 mx1 pmg-smtp-filter[21561]: 3C13E85DC1CE45F13FD: new mail message-id=<03dbc938e55e6aece8375a96cd81e0c3@skytechsport.com>
Do you send outgoing mails? If not, you may want to disable the advanced statistics filters flag.
The pmg-log-tracker relies on the timestamps to be formatted in a specific way for speed-reasons:
Nov  6 00:20:02

You need to adapt your rsyslog config to write the files with that format, if you want to use the logtracker (you can write the logs with ISO8601 in some other place if you need them)

I hope this helps!
Hi Stoiko.

Indeed this was the solution. We have now our own $ActionForwardDefaultTemplate and re-activated the $ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat aka Nov 6 00:20:02 : )

Thx, for the great support!
  • Like
Reactions: Stoiko Ivanov
Glad the solution worked out for you!
Please mark the thread as 'SOLVED' - it might help others in a similar situation



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!