[SOLVED] This system lacks PPP kernel support


Dec 6, 2018
Cape Town, South Africa

I'm getting this error below: (We migrated from a old cluster to the new pve6 cluster and now I'm getting this error)

root@illovo-pptp:~# pon illovo
Couldn't open the /dev/ppp device: Operation not permitted
modprobe: ERROR: ../libkmod/libkmod.c:507 kmod_lookup_alias_from_builtin_file() could not open builtin file '/lib/modules/5.0.15-1-pve/modules.builtin.bin'
/usr/sbin/pppd: Sorry - this system lacks PPP kernel support

What can I do to fix this and let me know if you need more details.


is this in a container? if yes, could you post the config?

Yes this is a container and below is the config:

root@ponder:~# cat /etc/pve/lxc/310.conf
arch: amd64
cpulimit: 1
cpuunits: 1024
hostname: xxxx-pptp.stonethree.com
memory: 1024
net0: name=eth0,bridge=vmbr0,firewall=1,gw=,hwaddr=02:FB:1E:07:A3:C4,ip=192.168.8.xxx/23,type=veth
ostype: ubuntu
rootfs: local-lvm:vm-310-disk-0,size=8G
swap: 1536

did you reboot after the upgrade? could you post pveversion -v too?

also: ls /lib/modules/*/modules.builtin.bin

Yes, restarted as well output below:

root@ponder:~# pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.15-1-pve)
pve-manager: 6.0-4 (running version: 6.0-4/2a719255)
pve-kernel-5.0: 6.0-5
pve-kernel-helper: 6.0-5
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.10-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-2
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-5
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-61
lxcfs: 3.0.3-pve60
novnc-pve: 1.0.0-60
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-5
pve-cluster: 6.0-4
pve-container: 3.0-3
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-5
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-2
pve-qemu-kvm: 4.0.0-3
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-5
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.1-pve1

could you try adding these to your container config:

lxc.cgroup.devices.allow: c 108:0 rwm
lxc.mount.entry: /dev/ppp dev/ppp none bind,create=file
  • Like
Reactions: guletz

please mark the thread as [SOLVED], it helps others.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!