The hard disk sm2262 controller cannot passthrough


New Member
Jul 15, 2023
I encountered an error when I tried to passthrough the HP SSD Ex920, which caused the virtual machine to fail to start normally, and the prompt is as follows
swtpm_setup: Not overwriting existing state file.
kvm: -device vfio-pci,host=0000:02:00.0,id=hostpci2,bus=pci.0,addr=0x1b: vfio 0000:02:00.0: failed to add PCI capability 0x11[0x50]@0xb0: table & pba overlap, or they don't fit in BARs, or don't align
stopping swtpm instance (pid 109194) due to QEMU startup error
TASK ERROR: start failed: QEMU exited with code 1

bug source
Solutions on the Internet (but Its not work)
args: -set device.hostpci0.x-msix-relocation=bar2

how do i fix it?[Thanks]
Last edited:
Hi, i am not sure if you have fixed the issue by now, but i ran into the same issue with an SM2263 controller device and the solution you posted worked. I belive you need to make sure the ID of hotpci on the args you are adding to the vm.conf file has to match the ID of your device so in your case the line should look like this:

args: -set device.hostpci2.x-msix-relocation=bar2


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!