Testing Proxmox 7.2 & Need Some Help Please

husskii

Member
Jun 19, 2022
10
1
8
Hi I am testing the Proxmox 7.2 ve on a old Toshiba Satellite L50-A i7 4th Gen with 16gb ram and for some reason when ever i reboot my system it just freezes on the blue screen, the GNU Grub page and i have to hit enter to boot into Proxmox. I've tried going through some posts and editing grub such as

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="quiet intel_iommu=on iommu=pt"

and

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"
GRUB_CMDLINE_LINUX=""

but still it doesn't help and when i update grub and reboot i still get stuck on the blue screen (pic below) until i hit enter.. I would prefer it to just boot into proxmox as eventually i want this environment in another part of the house and access it remotely.

Does anyone have any ideas on what's wrong and how to fix it please, I would really appreciate it.
its the same page as the pic below but with Grub 2.04-20 i just found this image on the forum and recycled it.

boot-grub.png


this is the page i am always stuck on until i hit enter on the physical machine.

Thanks in advance

***EDIT I have also noticed after reboot it always highlights the 2nd line for Advanced options for Proxmox Virtual Environment GNU\Linux
 
Last edited:
Grub may think it's failing to boot?

Here is a couple ways to test.

1) Add line GRUB_RECORDFAIL_TIMEOUT=0 to /etc/default/grub

update-grub and reboot to test

2) Add line GRUB_HIDDEN_TIMEOUT=-1 to /etc/default/grub

update-grub and reboot to test
 
  • Like
Reactions: husskii
Grub may think it's failing to boot?

Here is a couple ways to test.

1) Add line GRUB_RECORDFAIL_TIMEOUT=0 to /etc/default/grub

update-grub and reboot to test

2) Add line GRUB_HIDDEN_TIMEOUT=-1 to /etc/default/grub

update-grub and reboot to test
Hi and thanks for the reply, i tried each of the configs you mentions and this is what i get after updating grub

root@pve:~# update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-5.15.35-2-pve
Found initrd image: /boot/initrd.img-5.15.35-2-pve
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
Adding boot menu entry for EFI firmware configuration
done

and for some reason which might play a part in it but not sure. is the fact that after i reboot it highlights the 2nd line for
Advanced options for Proxmox Virtual Environment GNU\Linux
and not the 1st line
Proxmox Virtual Environment GNU\Linux

ive tried finding other posts regarding grub config and attempting to duplicate some of them but with no luck.

i dont know if this helps but when i try run the command proxmox-boot-tool refresh i get the following.

root@pve:~# proxmox-boot-tool refresh
Running hook script 'proxmox-auto-removal'..
Running hook script 'zz-proxmox-boot'..
Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace..
No /etc/kernel/proxmox-boot-uuids found, skipping ESP sync.
root@pve:~# reboot

and this is my grub.cfg file

root@pve:~# grep menu /boot/grub/grub.cfg
if [ x"${feature_menuentry_id}" = xy ]; then
menuentry_id_option="--id"
menuentry_id_option=""
export menuentry_id_option
set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue
menuentry 'Proxmox VE GNU/Linux' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-cf52538d-a5a7-4a1e-970e-577994003b63' {
submenu 'Advanced options for Proxmox VE GNU/Linux' $menuentry_id_option 'gnulinux-advanced-cf52538d-a5a7-4a1e-970e-577994003b63' {
menuentry 'Proxmox VE GNU/Linux, with Linux 5.15.35-2-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.15.35-2-pve-advanced-cf52538d-a5a7-4a1e-970e-577994003b63' {
menuentry 'Proxmox VE GNU/Linux, with Linux 5.15.35-2-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.15.35-2-pve-recovery-cf52538d-a5a7-4a1e-970e-577994003b63' {
menuentry "Memory test (memtest86+)" {
menuentry "Memory test (memtest86+, serial console 115200)" {
menuentry "Memory test (memtest86+, experimental multiboot)" {
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
root@pve:~#
 
Hello, I'm having a similar issue in PVE 7.3.6, is a recent install and everytime I need to reboot a have to connect a keyboard to continue
We're you able to solve the issue?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!