systemd can't start sshd after 5.x -> 6.x upgrade

Jan 12, 2015
Anyone know how to fix this? I can start sshd by hand using /usr/sbin/sshd -DDD and no errors are present. At boot however, systemd is having problems and I can't login. journalctl -xb says this:

pam_systemd(sshd:session): Failed to connect to system bus: No such file or directory


Proxmox Staff Member
Staff member
Nov 19, 2018

what does systemctl status dbus say? if it's not active, try starting the service (systemctl start dbus and enable)
Jan 12, 2015
Thanks for the reply. I think the ssh issue was due to being booted in "Emergency Mode" (single user mode?) and I'll bet you're right about dbus being disabled too. I started commenting things out of /etc/fstab and suddenly it booted normally. my /dev/pve/data partition seemed to be the problem and I have no idea why. It's a local partition which was previously mounted with noatime,nodiratime,defaults,relatime 0 1. I changed the fsck field to a 2 and added the noauto to hopefully get it out of any boot dependencies. That seems to have done the trick.

I've got five more hypervisors to upgrade, all configured the same way so we'll see how the rest go.


The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!